14

I would like to use biblatex in order to control for the amount of information which is outputed in the bibliography (e.g., doi, issn, urls) but the problem is that the original ACM Proceedings format produces abbrevated names while the default numeric format produces the full names in the bibliography. I'm not sure how to do this and I'm overwhelmed by the amount of customization that is possible to do.

Original version:

\documentclass{acm_proc_article-sp}

\usepackage{filecontents}
\usepackage{lipsum}

\begin{filecontents}{example.bib}
@book{book_2014,
  title = {Book Title},
  publisher = {{Publisher} Name},
  author = {Doe, John and Bar, Foo. and Jane Doe},
  month = april,
  year = {2014}
}
\end{filecontents}

\usepackage[utf8]{inputenc}
\usepackage[british,UKenglish,USenglish,english,american]{babel}
\usepackage[babel=true]{csquotes}
\usepackage{natbib}
\begin{document}

\lipsum{1}~\citep{book_2014}
\bibliographystyle{abbrv}
\bibliography{example}

\end{document}

original BibTeX version

Biblatex version

\documentclass{acm_proc_article-sp}

\usepackage{filecontents}
\usepackage{lipsum}

\begin{filecontents}{paper.bib}
@book{book_2014,
  title = {Book Title},
  publisher = {{Publisher} Name},
  author = {Doe, John and Bar, Foo. and Jane Doe},
  month = april,
  year = {2014}
}
\end{filecontents}

\usepackage[utf8]{inputenc}
\usepackage[british,UKenglish,USenglish,english,american]{babel}
\usepackage[babel=true]{csquotes}
\usepackage[firstinits=false,
            uniquename=false,
            uniquelist=false,
            hyperref=auto,
            maxbibnames=99,
            maxcitenames=2,
            style=numeric,
            citestyle=numeric,
            backref=false,
            natbib=true,
            backend=bibtex]{biblatex}

\DeclareFieldFormat{urldate}{}

\AtEveryBibitem{
 \clearlist{address}
 \clearfield{date}
 \clearfield{eprint}
 \clearfield{doi}
 \clearfield{isbn}
 \clearfield{issn}
 \clearlist{location}
 \clearfield{month}
 \clearfield{labelmonth}
 \clearfield{series}

 \ifentrytype{book}{
   \clearfield{url}
 }{
   \ifentrytype{misc}{
   }{
    \clearfield{url}
    \clearlist{publisher}
     \clearname{editor}
   }
 }
}

\bibliography{paper}

\begin{document}

\lipsum{1}~\citep{book_2014}
\printbibliography

\end{document}

Biblatex version

7
  • Welcome to TeX SE. It is great that you provide some code and you can make it much more useful by completing it to create a minimal working example (MWE) that illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}.
    – cfr
    Apr 18 '14 at 2:33
  • I've found a solution, it is the style=trad-abbrv in the biblatex usepackage statement Apr 18 '14 at 4:17
  • firstinits=true is the secret option you are looking for (oddly enough though you explicitly set firstinits=false, why?). There is no point in setting citestyle to numeric, if style is already numeric. hyperref=auto is already the default setting, so no need to repeat it in the preamble. Furthermore you might want to think about switching to Biber (backend=biber) instead of BibTeX (the uniquename and uniquelist features are only available with Biber, they are all set to false by default as well, so no need to mention them either).
    – moewe
    Apr 18 '14 at 6:53
  • Another note: If you want to suppress the output of the urldate, \DeclareFieldFormat{urldate}{} is not a good idea (I'm not really sure whether it has any effect at all). Furthermore, the \bibliography command is deprecated in favour of \addbibresource, so write \addbibresource{paper.bib} (note the file extension, has to be included here) instead of \bibliography{paper}. To suppress doi, isbn etc. it is generally preferred to use doi=false, isbn=false as a load-time option (this will only work for some fields though, consult the manual for further information about that).
    – moewe
    Apr 18 '14 at 7:04
  • Thanks a lot for the comments, I've switched to Biber, previously I had some problems with it, but now everyting works so I'm going to use it form now :) Some of the staff that is there is left from thee other paper I was writing that used author-year format so I was setting all those things things that do not make much sense for this case Apr 18 '14 at 9:15
8

I found the solution. The style which is used by the ACM Proceedings format can be specified using style=trad-abbrv in the usepackage statement.

1
  • You might also want to mention the firstinits=true option.
    – moewe
    Apr 20 '14 at 10:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.