After reading many great things about biblatex in the forum, I would like to start using it. I tried the steps given in What to do to switch to biblatex? on a file on which I am already using BibTeX, but received an Undefined-Control-Sequence error on \addbibresource.

I set up an example document copying from the files in http://www.ctan.org/tex-archive/macros/latex/contrib/biblatex//doc/examples, (01-introduction.tex and biblatex-examples.bib) and got the same error.

I am using AucTeX 11.866 with TeXLive 2009. Below is the document I am trying to compile, along with the error it outputs. I am using the Default engine and generating a PDF (or trying to). What should I do to make this work?





% biblatex-examples.bib is located in ~/Library/texmf/bibtex/bib/


\section*{Name of first section here}

This is just filler text \parencite{companion}.

This is just filler text \parencite[59]{companion}.

This is just filler text \parencite[see][]{companion}.

This is just filler text \parencite[see][59--63]{companion}.



Here's the error:

ERROR: Undefined control sequence.

--- TeX said ---
l.11 \addbibresource
--- HELP ---
TeX encountered an unknown command name. You probably misspelled the
name. If this message occurs when a LaTeX command is being processed,
the command is probably in the wrong place---for example, the error
can be produced by an \item command that's not inside a list-making
environment. The error can also be caused by a missing \documentclass

AUCTeX has nothing to do with this. The problem is that \addbibresource has been added to biblatex from version 1.2, which is not in TeX Live 2009.

The best is to upgrade by downloading MacTeX 2010 from http://tug.org/mactex and running TeX Live Manager to get an up-to-date distribution (I assume you are on Mac OS X from the

% biblatex-examples.bib is located in ~/Library/texmf/bibtex/bib/


| improve this answer | |
  • 3
    To use the older biblatex version included in TeX Live 2009, replace \addbibresource{<name>.bib} with \bibliography{<name>}. – lockstep May 2 '11 at 23:14
  • It's going to be a couple of days before I can upgrade and verify this, but you make a strong point. Thanks for the answer! – Ricardo May 4 '11 at 4:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.