3

As the title says.

\documentclass[reprint, prb]{revtex4-1}
\usepackage{scrextend}

\begin{document}

some text here.
\footnote{aaa}

\end{document}

This does not produce any footnote. It simply gives the above mentioned warning. (My main text is much larger but I just wanted to give an example. In the main text it actually also give a warning: Citation Note0 on page 1 is undefined.)

I have looked into other similar problems here in TS but nothing solving my problem. Thanks.

  • 1
    Welcome to TeX SE! According to the author guide for revtex4, footnotes appear in the bibliography by default. If you want them at the bottom of the page, pass nofootinbib to the class. prb puts footnotes at the start of the bibliography... – cfr Apr 21 '14 at 21:23
5

By default, revtex4-1 puts footnotes in the bibliography. This can be disabled with nofootinbib but prb puts them at the start of the bibliography anyway. So to get footnotes at the bottom of the page, you'd need:

\documentclass[reprint, nofootinbib]{revtex4-1}
\usepackage{scrextend}

\begin{document}

some text here.
\footnote{aaa}

\end{document}

Footnotes at bottom of page

Otherwise, you need to typeset your bibliography for the notes to show up:

\documentclass[reprint, prb]{revtex4-1}
\usepackage{scrextend}

\begin{document}

some text here.
\footnote{aaa}

\bibliography{apssamp}

\end{document}

Footnotes in bib <code>prb</code> option

| improve this answer | |
  • Thanks! I actually knew about nonfootinbib but as you said it won't work unless prb is removed. Thank you. – student1 Apr 21 '14 at 21:39
  • @student1 You're welcome. Yes. It was adding nofootinbib and not getting a footnote which prompted me to look up prb ;). – cfr Apr 21 '14 at 21:42
  • Actually, it only works without prb, but without it the references now appear as [1] instead of 1 (superscript). What is the solution? – student1 Apr 23 '14 at 3:04
  • @student1 What makes it part of the abstract? I tried adding a new section with some more text and another note and that showed fine. (But if I use an abstract environment, I get neither abstract nor note.) – cfr Apr 23 '14 at 3:09
  • 1
    @student1 Yes, that's what prb does - more specifically, all notes are typeset at the start of the bibliography. If you are meant to use that option, I guess that's how they want the notes. That's why I said in my answer that you needed to remove that option as well to get nofootinbib working. – cfr Apr 23 '14 at 3:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.