0

I am using LyX and the report class. (KOMA-Script). My List of Figures just prints the figure number and its caption but not the word Figure infront. How could I modify the command in the Latex preamble?

  • Welcome to TeX.SX! Please help us to help you and add a minimal working example (MWE) that illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}. – user31729 Apr 22 '14 at 11:00
  • See tex.stackexchange.com/questions/12865, you can probably use the preamble in the accepted answer directly in LyX. – Torbjørn T. Apr 22 '14 at 11:34
  • Great!! Adding the tocloft package and redefining the command solved it! Thanks a lot Torbjørn! – Franziska Apr 22 '14 at 12:31
1

You can simple use the KOMA-Option listof=entryprefix. There are to possibilities:

\documentclass[listof=entryprefix]{scrreprt}

or

\documentclass{scrreprt}
\KOMAoptions{listof=entryprefix}

enter image description here

\documentclass{scrreprt}
\KOMAoptions{listof=entryprefix}

\begin{document}

\listoffigures

\chapter{First chapter}
\begin{figure}[!ht]
  \centering
  \rule{2cm}{2cm}
  \caption{test figure one}
  \label{fig:test1}
\end{figure}
\begin{figure}[!ht]
  \centering
  \rule{2cm}{2cm}
  \caption{test figure two}
  \label{fig:test2}
\end{figure}

\end{document}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.