7

I'm trying to install Vollkorn font from .otf files on OSX with the help of autoinst.

On a separate folder I run the command autoinst -target=~/Library/texmf/ Vollkorn-*.otf which should install the different versions of Vollkorn (http://vollkorn-typeface.com/).

Without luck so far this ends with such messages for all font variants:

  • otftotfm: encoding ‘fontools_ot1’ not found
  • otftotfm: encoding ‘fontools_t1’ not found
  • otftotfm: encoding ‘fontools_ly1’ not found

Finally, [WARNING] 'otftotfm' returned non-zero; something's wrong! at /usr/texbin/autoinst line 643.so that the operation has failed.

Note that LCDF-typetools are installed.

  • 3
    Is there any chance you can make the switch from pdfLaTeX to either XeLaTeX or LuaLaTeX? Given that the Vollkorn font comes in OpenType format, using either XeLaTeX or LuaLaTeX with this font would be trivially easy: You'd load the fontspec package and issue the command \setmainfont{Vollkorn}. – Mico Apr 22 '14 at 12:27
  • Don't install fonts for TeX into your home texmf tree unless you have no other options (e.g. you don't have admin rights on the machine). It is better to install into the local texmf tree (/usr/local/texlive/texmf-local) so that you don't have problems with updates. – cfr Apr 22 '14 at 21:13
  • Those encoding files are part of TeX Live so if you have the full version of MacTeX installed, you should have them. Is your TeX installation up to date? What does kpsewhich fontools_ot1.enc give? – cfr Apr 22 '14 at 21:15
  • It gives /usr/local/texlive/2013/texmf-dist/fonts/enc/dvips/fontools/fontools_ot1.enc – s__C Apr 23 '14 at 6:09
  • autoinst has an option to save rather than executing the commands needed to install fonts. Try using that option to see exactly how it is trying to use otftotfm as it is difficult to know what might be going wrong when the process is hidden by a wrapper. – cfr Apr 26 '14 at 0:49
0

This may not totally solve the problem (I'm not sure I succeeded in getting autoinst to work properly), but at least I no longer get the error messages.

The problem seems to be that otftoftm cannot find the encoding files that are in the fontools directory (fontools_ot1.enc, etc.). If you copy those files to wherever you are running autoinst from, otftoftm should be able to find them.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.