6

How can I get biblatex to print the full date in the references? I could have sworn it used to do this all by itself and I've got some old files where I've managed this, but I can't see anything in the .tex file or in the biblatex manual that says how to do it.

\documentclass{article}
\usepackage[style=authoryear-icomp,backend=biber]{biblatex}

\begin{filecontents}{references.bib}
    @article{Article,
  title = {This is a Title},
  author = {Author, Some},
  journal = {Journal},
  location = {The City},
  publisher = {Publisher},
  date = {2014-04-23}
}
\end{filecontents}
\addbibresource{references.bib}


\begin{document}
Citing \cite{Article}.
\printbibliography
\end{document}

Lack of full date in bibliography

3
  • 2
    Does mergedate=false, mergedate=compact or mergedate=minimum help? Please see The mergedate option in the quide to The authoryear-icomp style. You probably want mergedate=basic. – moewe Apr 23 '14 at 12:12
  • mergedate=basic, mergedate=false, and mergedate=minimum all seem to have more or less the same effect and put the date just after the title or the journal title, which I'm quite happy with, although I do remember that it did used to appear after the author. Thanks very much! – jaimepapier Apr 23 '14 at 21:46
  • There are minute differences between the three as explained in the document above, you might not notice them in your document though. If you prefer to get the full date in the parentheses after the author that could probably be arranged as well. Have a look at the datelabel option (p. 51 of the biblatex documentation), you could give datelabel=comp a try. – moewe Apr 24 '14 at 4:54
7

The mergedate option is what you are looking for. See The authoryear-icomp style.


You might like mergedate=false.

mergedate=false strictly separates the date specification from the date label. The year will always be printed twice.

enter image description here

All dates are printed twice.


Or mergedate=minimum

mergedate=minimum merges the dates whenever the full date and the date label are exactly the same string. If the date is a bare year number and there is no extrayear field, the date specification will be omitted.

enter image description here

Knuth 1948's date is not printed twice here.


Or mergedate=basic

mergedate=basic [...] will always omit the date specification if the date is a bare year number.

enter image description here

Knuth 1986a and Knuth 1986b's date are not printed twice either.


If you prefer the date to go into the parentheses at the front, you can use the datelabel option. The default value is year, so you only get to see the year. You can choose between year, short, long, terse, comp and iso8601 (see pp. 50-51 of the biblatex documentation). The latter options print the full date.

This option is probably best used with the default mergedate=compact option.

MWE

\documentclass{article}
\usepackage[style=authoryear-icomp,backend=biber,datelabel=comp]{biblatex}
\addbibresource{biblatex-examples.bib}

\begin{document}
  \nocite{baez/online,shore,knuth:ct:a,knuth:ct:b,knuth:ct:c}
  \printbibliography
\end{document}

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.