0

Trying to remove the indentation which is appearing around my abstract for some unknown reason. A MWE is below:

\documentclass[a4paper,oneside,10pt]{article}
\usepackage[english]{babel} % formatting rules for the English language
\usepackage[T1]{fontenc} % proper formatting for accented characters and non-standard characters such as pipelines
\usepackage{mathptmx}% fot a font which looks like Times New Roman (serif/roman)
%\usepackage{tgtermes}% an altternative
\usepackage[scaled=.90]{helvet}% for a font which looks like Helvetica, scaled to match TNR (sans)
%\usepackage{tgheros}% an altternative
\usepackage{courier}% for a font which looks like Courier (typewriter/monospaced)
%\usepackage{tgcursor}% an altternative
\usepackage[top=15mm, bottom=15mm, left=30mm, right=30mm]{geometry} % page layout
\setlength{\parindent}{0mm} % Do not indent the 1st line of a paragraph.
\setlength{\parskip}{3mm}   % Add space between paragraphs.


%% redefine \footnoterule for using the whole text width
\renewcommand\footnoterule{%
  \kern-3\p@\hrule\@width\columnwidth\kern 2.6\p@
}

\begin{document}

\renewcommand*\abstractname{\flushleft\textbf{ABSTRACT}\hfill}
\begin{abstract}
\noindent This is my abstractThis is my abstractThis is my abstractThis is my abstractThis is my abstractThis is my abstractThis is my abstractThis is my abstractThis is my abstractThis is my abstractThis is my abstractThis is my abstractThis is my abstractThis is my abstractThis is my abstractThis is my abstractThis is my abstractThis is my abstractThis is my abstractThis is my abstractThis is my abstractThis is my abstract
\end{abstract}

Some other stuffSome other stuffSome other stuffSome other stuffSome other stuffSome other stuffSome other stuffSome other stuffSome other stuffSome other stuffSome other stuffSome other stuffSome other stuffSome other stuffSome other stuffSome other stuffSome other stuffSome other stuffSome other stuffSome other stuffSome other stuffSome other stuff
\end{document} 
2

Use the abstract package which allows for indent/margin settings via \setlength definitions. See http://mirrors.ctan.org/macros/latex/contrib/abstract/abstract.pdf for the documentation.

In this case, I have set \absleftindent and \absrightindent both to 0mm. Change at will.

\documentclass[a4paper,oneside,10pt]{article}
\usepackage[english]{babel} % formatting rules for the English language
\usepackage[T1]{fontenc} % proper formatting for accented characters and non-standard characters such as pipelines
\usepackage{mathptmx}% fot a font which looks like Times New Roman (serif/roman)
%\usepackage{tgtermes}% an altternative
\usepackage[scaled=.90]{helvet}% for a font which looks like Helvetica, scaled to match TNR (sans)
%\usepackage{tgheros}% an altternative
\usepackage{courier}% for a font which looks like Courier (typewriter/monospaced)
%\usepackage{tgcursor}% an altternative
\usepackage[top=15mm, bottom=15mm, left=30mm, right=30mm]{geometry} % page layout

%%%% Additions for TeX.StackExchange
\usepackage{abstract}
\setlength{\absleftindent}{0mm}
\setlength{\absrightindent}{0mm}


\setlength{\parindent}{0mm} % Do not indent the 1st line of a paragraph.
\setlength{\parskip}{3mm}   % Add space between paragraphs.


%% redefine \footnoterule for using the whole text width
\renewcommand\footnoterule{%
  \kern-3\p@\hrule\@width\columnwidth\kern 2.6\p@
}

\begin{document}

\renewcommand*\abstractname{\flushleft\textbf{ABSTRACT}\hfill}
\begin{abstract}
\noindent This is my abstractThis is my abstractThis is my abstractThis is my abstractThis is my abstractThis is my abstractThis is my abstractThis is my abstractThis is my abstractThis is my abstractThis is my abstractThis is my abstractThis is my abstractThis is my abstractThis is my abstractThis is my abstractThis is my abstractThis is my abstractThis is my abstractThis is my abstractThis is my abstractThis is my abstract
\end{abstract}

Some other stuffSome other stuffSome other stuffSome other stuffSome other stuffSome other stuffSome other stuffSome other stuffSome other stuffSome other stuffSome other stuffSome other stuffSome other stuffSome other stuffSome other stuffSome other stuffSome other stuffSome other stuffSome other stuffSome other stuffSome other stuffSome other

 stuff
\end{document} 

enter image description here

  • The package also provides a absparindent macro to adjust the paragraph indentation in the abstract, but setting \setlength{\absparindent}{0em} has no effect here. – Sverre Apr 24 '14 at 10:16
  • Re my previous comment, it's because the abstract package contains a line that sets the length of \absparindent to the length of \parindent. I find this very odd, since that cancels the effect of changing \absparindent. – Sverre Apr 24 '14 at 10:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.