My question has been asked before but none of the answers previously has answered my question. I have an .eps file that I want to include in my LaTeX document. For this purpose I have included the epstopdf package. However, when I try to compile my document by using pdflatex, I get the error message File 'foo-eps-converted-to-pdf' not found. In the log file it says:

{/var/lib/texmf/fonts/map/pdftex/updmap/pdftex.map}] [2]
Package epstopdf Info: Source file: <Aoo.eps>
(epstopdf)                    date: 2014-04-28 18:54:16
(epstopdf)                    size: 18858 bytes
(epstopdf)             Output file: <foo-eps-converted-to.pdf>
(epstopdf)             Command: <epstopdf --outfile=foo-eps-converted-to.pdf foo.eps>
(epstopdf)             \includegraphics on input line 142.
runsystem(epstopdf --outfile=foo-eps-converted-to.pdf foo.eps)...disabled.

Package epstopdf Info: Result file: <foo-eps-converted-to.pdf>.

! Package pdftex.def Error: File `foo-eps-converted-to.pdf' not found.

See the pdftex.def package documentation for explanation. Type  H
<return>  for immediate help.  

l.142 \includegraphics{foo.eps}

It should be noted that all files are in the same directory, so there shouldn't be any issues with that.

Any suggestions? Thanks in advance!


The important line of the .log file is:

runsystem(epstopdf --outfile=foo-eps-converted-to.pdf foo.eps)...disabled.

The conversion do not work, because the shell escape feature is not enabled. Probably you are using an older TeX distribution. TeX Live and MiKTeX have a the restricted shell escape feature enabled by default.

On older systems (not too old, of course) the following option should work:

pdflatex --shell-escape

or (MiKTeX)

pdflatex --enable-write18
  • Thanks for your suggestion! I tried it, but unfortunately it didn't work. I also got the same line that you quoted in the log file. My TeX system is probably not too old; I downloaded it in 2012. – user50733 Apr 28 '14 at 21:01
  • Which TeX distribution and version do you use? Any message on the console about unrecognized option '-shell-escape'? – Heiko Oberdiek Apr 28 '14 at 21:28
  • It worked now! I was stupid enough to write "pdflatex filename --shell-escape" rather than "pdflatex --shell-escape filename" the first time. What does, in fact, "-shell-escape" do? – user50733 Apr 28 '14 at 21:31
  • To answer your question, I use TeX Live 2009 for Debian. – user50733 Apr 28 '14 at 21:36
  • -shell-escape allows the execution of external programs. In this case the program epstopdf converts the EPS file to PDF, which is then included. – Heiko Oberdiek Apr 28 '14 at 21:50

I had a similar problem on a Mac and it gave me a real headache. The following helped me

In my log file I had:

runsystem(epstopdf --outfile=foo-eps-converted-to.pdf foo.eps)...executed

I was however told that:

dyld: Library not loaded: /usr/X11/lib/libXt.6.dylib
Referenced from: /usr/local/bin/gs
Reason: image not found

and so subsequently:

! Package pdftex.def Error: File `foo-eps-converted-to.pdf' not found.

Turned out to be a problem with upgrading to Yosemite where X11 is moved from usr/X11 to opt/X11. I found another post about this which recommended manually adding a link:

sudo ln -s /opt/X11 /usr/X11

For me this solved the problem.


I also had this issue on my Mac with macOS 10.12. Apple is not including X11 anymore, which is required for epstopdf. You need to download it at https://www.xquartz.org After that, all my eps files just run smoothly.

  • Could you perhaps describe a little more how to install it? As it stands it is more of a "link-only" answer, which are discouraged on this site. – Henri Menke Jun 19 '17 at 3:32

Just in case somebody else stumbles upon the same error message. In my case the issue emerged from the file path of the *.eps file referenced in the *.eps_tex file, since I had all my pics in a separate subfolder called pics.



in the foo.eps_tex file to


solved the problem.

Maybe this helps somebody.


On Texmaker 5.0.3 (compiled with Qt 5.11.3), changing compiler to XeLateX made the trick for me:

xelatex -synctex=1 -interaction=nonstopmode %.tex

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.