5

How do I make Arev the font for the sans-serif family, but nothing else? I tried using

\usepackage{arev}
\usepackage[T1]{fontenc}

as instructed on this page, but that made everything sans-serif. I want the body of my text and everything from math mode and stuff to be roman, specifically Antiqua. Anywhere where I havent specified

\sffamily

I want to be in something different from Arev.

I have tried coming up with a solution using different ways, but none got me all the way where I wanted, and most were quite messy. Anyone know of a quick fix? Doesn't sound like it should be that hard.

  • 1
    Welcome to TeX.SX! Use \renewcommand{\sfdefault}{fav} instead of \usepackage{arev}, which is quite a “greedy” package. – egreg Apr 29 '14 at 9:37
4

The package arev is “greedy”: it changes everything to (the Arev clone of) the Vera Sans font.

The arevtext.sty package essentially does

\renewcommand{\rmdefault}{fav}
\renewcommand{\sfdefault}{fav}
\renewcommand{\ttdefault}{fvm}

and you just need the second line. So

\documentclass{article}
\usepackage[T1]{fontenc}

\renewcommand{\sfdefault}{fav}

should do what you want.

  • Thanks a bunch! I also wanted to try the Gillius package, but this one also seems to be fairly greedy. However, I can't make out anything by reading its .sty files. Any ideas? – Delta t Apr 30 '14 at 8:45
  • 1
    @Deltat gillius should act only on the sans serif family, if not called with the default option. So \usepackage{gillius} should work. – egreg Apr 30 '14 at 9:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.