7

I would like to Kile autocomplete my citations, so when I type \citep{ a list with my bibliography entries pops up. I tried also by typing the first 3 letters of the entry key, and/or pressing Ctrl+Space, but no luck. Autocompletion when writing the text or other commands/environments do work.

I have tried other suggestions (http://ubuntuforums.org/archive/index.php/t-1003107.html), but it doesn't work for me.

I use one master file.tex that then call several .tex files with the command \input{files}. The library .bib file containing my bibtex items is located into the same folder as all the .tex files.

In the preamble I use \usepackage{natbib}, and I insert the bibliography as usual with \bibliography{library}. Still I don't get autocomplete to work.

Do you have any ideas? Thanks in advance.

  • Are your .bib files and the .tex files part of a project in Kile? I think Kile might require that to access the right bib file for autocompletion. – FrankD Jul 9 '16 at 9:48
0

I encountered the same problem that Kile (2.9.93 on LinuxMint 19) did not autocomplete bibtex entries.

In my case, this was caused by a somewhat unusual organization of project files: I have the bib file in a central place and placed a symbolic link into my project directory. For BiTeX that was fine, but Kile (2.9.93) did not autocomplete bibtex entries.

The solution for that (unusual) case was to replace the symbolic link with a hard link.

  • 1
    Its unclear how your answer solves OP's problem. – Raaja Jul 31 at 10:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.