2

I would like to draw some chemical equipment and I found this pst-labo package. However, it does not work for me and I am sure I have the package installed.

This should be a very simple example of its usage which does not work for me:

\documentclass{article}
\usepackage[utf8]{inputenc}
\usepackage{pst-labo}

\title{Blank}
\date{April 2014}

\begin{document}

\maketitle

\section{Introduction}

\psset{unit=0.5cm}
\pstTubeEssais

\end{document}
  • 3
    How are you trying to compile the document? pdflatex? pstricks (the package working behind the scenes) requires latex->dvips->ps2pdf to be used. – Paul Gessler May 1 '14 at 21:46
  • 2
    Or you can add \usepackage[pdf]{pstricks} to your preamble, and compile with pdflatex. – Bernard May 1 '14 at 21:50
  • By adding \usepackage[pdf]{pstricks} to my preamble to the code showed before still reports error and does not compile with PdfLaTeX. – Garret May 1 '14 at 22:58
  • If you go back to the original code, does latex work? – cfr May 2 '14 at 2:00
1

Run the document with xelatex (without loading package inputenc) or run it with pdflatex --shell-escape <file> with loading package auto-pst-pdf:

\documentclass{article}
\usepackage[utf8]{inputenc}
\usepackage[crop=off]{auto-pst-pdf}
\usepackage{pst-labo}

\title{Blank}
\date{April 2014}

\begin{document}

\maketitle

\section{Introduction}

\begin{postscript}
\psset{unit=0.5cm}
\pstTubeEssais
\end{postscript}

\end{document}

My output with xelatex and current TeXLive 2013

enter image description here

  • Using that code and compiling with pdflatex still does not show the equipment figure. Texkstudio says: auto-pst-pdf: . Or turn off auto-pst-pdf.}. Furthermore, copying the code also into sharelatex does not show the figure either. – Garret May 2 '14 at 6:51
  • I suppose that you are missing the option --shell-escape. Howver, can't you use xelatex then there is no need for using auto-pst-pdf – user2478 May 2 '14 at 6:58
  • Even using xelatex I cannot see the equipment. Did you try the code personally? – Garret May 3 '14 at 11:04
  • see my added image in my answer – user2478 May 3 '14 at 11:48
  • That works for me using xelatex from texlive 2014. I had to change the postscript to pspicture though. – ezietsman Aug 20 '14 at 8:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.