1

I'm using the below coding to get the footnote style. After creating the PDF, if I click the footnote number it goes at the second line of "first footnote text" and not the first line. Also, the second footnote contains a just a single line of text. If I click the second footnote, it goes to the third footnote text.

Kindly suggest how to go the first line of each footnote instead of the second line.

\documentclass{article}

\usepackage[hyperfootnotes,raiselinks]{hyperref}
\hypersetup{
    colorlinks,%
    citecolor=blue,%
    filecolor=blue,%
    linkcolor=blue,%
    urlcolor=blue
}

\usepackage{footnote}

\begin{document}

This is a sample text. This is a sample text. This is a sample text. This is a sample text.
This is a sample text. This is a sample text. This is a sample text. This is a sample text.
This is a sample text.\footnote{Footnote text Footnote text Footnote text Footnote text Footnote text Footnote text
Footnote text Footnote text Footnote text Footnote text Footnote text} This is a sample text. This is a sample text. This is a sample text.
This is a sample text. This is a sample text. This is a sample text. This is a sample text.

This is a sample text. This is a sample text. This is a sample text. This is a sample text.
This is a sample text. This is a sample text. This is a sample text. This is a sample text.
This is a sample text.\footnote{Footnote text Footnote text Footnote text Footnote text Footnote} This is a sample text. This is a sample text. This is a sample text.
This is a sample text. This is a sample text. This is a sample text. This is a sample text.

This is a sample text. This is a sample text. This is a sample text. This is a sample text.
This is a sample text. This is a sample text. This is a sample text. This is a sample text.
This is a sample text.\footnote{Footnote text Footnote text Footnote text Footnote text Footnote text Footnote text
Footnote text Footnote text Footnote text Footnote text Footnote text} This is a sample text. This is a sample text. This is a sample text.
This is a sample text. This is a sample text. This is a sample text. This is a sample text.

.....
.....
.....

\end{document}
1
  • It worked for me with MikTeX 2.9 and Adobe Acrobat (viewer). I had to zoom in to be able to tell precisely where the upper left corner was, and in each case it was just to the right of the footnote number. May 6, 2014 at 13:47

1 Answer 1

1

Sorry, actually I'll post this as a comment, but I can't. So I decide to post as an answer.

First, I think the problem is on your apps (maybe?). I've tested your original code with a bit modification and it's work perfectly. I've tested with Document Viewer and Foxit Reader 6.14 on Ubuntu 14.04.

I've provide 2 code that you can test them. The first is a bit modification from your original code. second, just replace your dummies text with a long text. So, you can see what exactly footnote pointer point to.

first code

\documentclass{article}

\usepackage[hyperfootnotes,raiselinks]{hyperref}
\hypersetup{
    colorlinks,%
    citecolor=blue,%
    filecolor=blue,%
    linkcolor=blue,%
    urlcolor=blue
}

\usepackage{footnote}

\begin{document}

This is a sample text. This is a sample text. This is a sample text. This is a sample text.
This is a sample text. This is a sample text. This is a sample text. This is a sample text.
This is a sample text.\footnote{Footnote text Footnote text Footnote text Footnote text Footnote text Footnote text
Footnote text Footnote text Footnote text Footnote text Footnote text} This is a sample text. This is a sample text. This is a sample text.
This is a sample text. This is a sample text. This is a sample text. This is a sample text.

This is a sample text. This is a sample text. This is a sample text. This is a sample text.
This is a sample text. This is a sample text. This is a sample text. This is a sample text.
This is a sample text.\footnote{Footnote text Footnote text Footnote text Footnote text Footnote} This is a sample text. This is a sample text. This is a sample text.
This is a sample text. This is a sample text. This is a sample text. This is a sample text.

This is a sample text. This is a sample text. This is a sample text. This is a sample text.
This is a sample text. This is a sample text. This is a sample text. This is a sample text.
This is a sample text.\footnote{Footnote text Footnote text Footnote text Footnote text Footnote text Footnote text
Footnote text Footnote text Footnote text Footnote text Footnote text} This is a sample text. This is a sample text. This is a sample text.
This is a sample text. This is a sample text. This is a sample text. This is a sample text.

.....
.....
.....
\newpage
test
\end{document}

screenshot #1 (with document viewer) enter image description here

second

\documentclass{article}

\usepackage[hyperfootnotes,raiselinks]{hyperref}
\hypersetup{
    colorlinks,%
    citecolor=blue,%
    filecolor=blue,%
    linkcolor=blue,%
    urlcolor=blue
}

\usepackage{footnote}

\usepackage{lipsum}

\begin{document}
\footnote{\lipsum[1]}\lipsum[1]
\footnote{\lipsum[2]}\lipsum[2]
\footnote{\lipsum[3-6]}\lipsum[3]
\end{document}

screenshot #2 (with document viewer) enter image description here

2
  • Thank you for your immediate response. But still the same problem. I have tried in MikTex 2.7 and 2.9 in Windows 7.
    – user38642
    May 6, 2014 at 9:05
  • which pdf reader that you used? May 8, 2014 at 22:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .