12

I'd like to use authoryear-comp for my bibliography. However, I'd like to suppress underlining the journal title that seems to be set default.

Also, I got the problem that a line break is not inserted into the journal title, so that the title extends beyond the border. Is there a way to change this?

Here is an MWE:

\documentclass[12pt]{scrbook}
\usepackage[style=authoryear-comp, maxnames=1, doi=false, url=false, backend=bibtex8]{biblatex}
\bibliography{LitThesis}

\begin{document}
Here is my reference \parencite{Hummelen1997}.

\printbibliography

\end{document}

Bibtex code:

@ARTICLE{Hummelen1997,
author = {the author},
title = {the title},
journal = {Chemistry},
year = {1997},
volume = {3},
pages = {1489--1493},
number = {9},
month = {09}
}

So concerning the problem with the month I tried to do the following:

\usepackage[style=authoryear-comp, maxnames=1, doi=false, url=false, month=false, backend=bibtex8]{biblatex}

But I get an error because "month" is not recognized as a value. Is there a way to suppress showing the month in the bibliography?

11
  • Welcome to tex.sx! You don't have to sign with your name since it automatically appears in the lower right corner of your post.
    – Joseph Wright
    Commented May 6, 2011 at 9:56
  • 2
    @Anja: It sounds as if you are loading a package which redefined \emph to underline. Please add a minimal working example (MWE) that illustrates your problem.
    – Joseph Wright
    Commented May 6, 2011 at 9:57
  • You can try \DeclareFieldFormat[article]{title}{#1\isdot} but an example might be needed. I hav not used this style in a while but I don't remember anything beeing underlined
    – Martin H
    Commented May 6, 2011 at 9:57
  • 2
    @ Joseph: While creating an MWE I noticed that indeed I had the ulem-package that was causing this problem. Upon removal of the package both problems were solved. Thank you!
    – Anja
    Commented May 6, 2011 at 10:08
  • 1
    @Anja: You can load the package ulem with the option normalem Commented May 6, 2011 at 10:47

3 Answers 3

6

How to hide month in the bibliography:

\documentclass[12pt]{scrbook}
\usepackage[style=authoryear-comp, maxnames=1, doi=false, url=false, backend=bibtex8]{biblatex}
\bibliography{LitThesis}
\AtEveryBibitem{%
  \clearfield{month}%
}
\begin{document}
Here is my reference \parencite{Hummelen1997}.

\printbibliography

\end{document}
0
3

To suppress underlining the journal title (and allow line breaks):

\makeatletter
\long\def\emph#1{\ifmmode\nfss@text{\em #1}\else\hmode@bgroup\text@command{#1}\em\check@icl #1\check@icr\expandafter\egroup\fi}
\makeatother

You may check this post for \emph redefinition in beamer.

3
  • 1
    Welcome to TeX.SX! Perhaps you can extend your answer by providing a complete minimal working example to the OP. Commented Mar 13, 2014 at 10:16
  • 1
    Well this works for me, thanks! But is there no easier solution for this? For example a package option would be nice. Why is biber underlining the journal title by standard?
    – tc88
    Commented Jul 30, 2015 at 14:32
  • @tc88: Afaik, biber is not underlining the journal title, rather biber is using \emph{...}. But the ulem package apparently defines \emph to be underline; passing the normalem option when loading ulem (as suggested by Marco Daniel in a comment up higher) prevents this, and is an easier and cleaner solution. Commented Oct 20, 2017 at 16:58
3

Although the MWE in the question does not show it, the comments indicate that in the real document the ulem package was used. This causes underlining of text that is displayed with \emph, which is used for journal titles. To prevent underlining the following package option can be used:

\usepackage[normalem]{ulem}

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .