4

I'm currently working on my thesis and I am trying to cite a Dutch author. Some Dutch surnames have a "von" component (e.g., van, van der, de) which should be capitalized if and only if the first name is not included.

To remedy this, natbib allows you to use either \citet or \Citet to manage the capitalization. The \Citet command, however, seems to be broken when the numbers option is used. In this case, the "von" component is left uncapitalized.

Below I have included a MWE.

.tex:

\documentclass{article}
\usepackage[numbers]{natbib}

\begin{document}

\citet{vannoort}

\Citet{vannoort}

\bibliography{library}
\bibliographystyle{unsrtnat}

\end{document}

.bib:

@article{vannoort,
author={van Noort, Thomas},
title={An important paper},
year=2010,
}

Is there a way to solve this?

  • 1
  • I did. But this really seems like a hack. Note that the problem only occurs with the numbers argument. Were it to be removed, the \Citet command correctly capitalizes the name. So I think it's a bug in the natbib package. – irundaia May 7 '14 at 21:35
  • Not a real answer (for natbib), but I just want to point out that biblatex doesn't have this problem. \usepackage[natbib,useprefix]{biblatex} and \addbibresource{library.bib} in the header, and the two cites give different results as intended. – pst May 7 '14 at 21:49
  • 2
    It really seems a bug in natbib, because the code for the capitalization is never executed with the numbers option. – egreg May 7 '14 at 21:49
  • @egreg Thanks for pointing out that is was a bug. I report it, and it will be fixed soon. – Clément Jun 6 at 13:50
1

I ran into this issue as well and emailed the maintainer of natbib to report the bug, using the contact email provided in the documentation.

Here is the most relevant part of the reply:

I will submit a new version shortly […]. For now you can make the following fix: On line 494 of natbib.sty, replace

\else \NAT@nm

with

\else \NAT@nmfmt{\NAT@nm}%

So it was indeed a bug, and it will be fixed soon :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.