2

Situation: I'm trying to spell check for German in Lyx on Ubuntu 14.04. Currently I'm having Enchant selected under Preferences, but I'm open to any alternative to gain "in document" spell checking functionality.

Problem: There is no spelling checked. F7 prints out "Spell checker has no dictionaries."

Note: Spell checking for German works wonderfully in all my other applications I use like browsers or LibreOffice.

  • Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format. – user31729 May 10 '14 at 16:36
  • Which dictionaries do you have installed for German? Which are your other applications using? Have you checked for additional enchant/lyx language packs in your package manager? – cfr May 10 '14 at 23:50
  • Does spell checking work in other languages (e.g. English)? Enchant works well for me on Ubuntu 14.04. You might consider hunspell just to try something different though. Note that if you try hunspell you will have to give LyX the path under tools > preferences > paths – scottkosty May 11 '14 at 9:10
  • Apparently, Libreoffice is using Hunspell. I can select a German or Englisch dictionary there. Under "paths" in Lyx, I can't select a path for Hunspell. The field is grayed out. Under "Spellchecker engine" my only option is Enchant. How do I select Hunspell, considering that it is somehow installed on my box being used in Libreoffice? – supercuteboy May 12 '14 at 5:34
  • @supercuteboy quick SE tip: you need to respond with "@", otherwise I will not know that you responded to me (there's no subscription based on a comment). Luckily I checked back here. – scottkosty May 12 '14 at 7:45
2

I had a similar problem with the standard English dictionary (when clicking on Tools the tab Spellchecker F7 was grayed out)

I am using ubuntu 16.01 and LyX version 2.1.4

The following solved my problem. Inside

Tools > Preferences > Language Settings > Spellchecker > Spellchecker engine

select Enchant from the drop down menu.

1

Note that this was solved through email by configuring the PPA on Ubuntu. Below is an alternate solution.

To use Hunspell, one must enter the path in Tools > Preferences > Paths. This was greyed out in the OP's case. Thus, a reinstall of LyX from the Ubuntu PPA fixed it, because that version was built with support for Hunspell.

Note that on Linux systems other than Ubuntu, you might need to compile LyX yourself to add support for spell checking. The following instructions might thus be needed by some.

Do the following steps:

  1. sudo apt-get build-dep lyx 0.5 sudo apt-get install cmake
  2. make a directory such as "local_lyx" wherever you want. cd into that directory
  3. run git clone git://git.lyx.org/lyx repo
  4. now run wget https://github.com/scottkosty/lyx-tester/raw/master/lyxbuild
  5. chmod +x lyxbuild
  6. cd repo
  7. to build in parallel run ../lyxbuild --jobs $( grep "processor" /proc/cpuinfo | wc -l )
  8. when that is done, run cd ../CMakeBuild
  9. test LyX from there: ./bin/lyx2.2
  10. Now install it: sudo make install
  11. Now run lyx2.2
  12. Go to Tools > Preferences > Paths and put /usr/share/hunspell/ for the hunspell path
  13. Test that both Hunspell and Enchant work. Note that you might have to Tools > reconfigure after putting in the Hunspell path, and when you switch between spell checkers.

If the build fails (that is if the command in 6. does not have a zero exit code), then please post the output of the command in 6. as well as the logs in local_lyx/build-logs.

  • When running (7) the terminal returns: lyxbuild: running git clean... lyxbuild: removing previous build logs... lyxbuild: creating "CMakeBuild" dir and running cmake... lyxbuild: ERROR: running cmake The error message in the logs say: CMake Error at development/cmake/modules/FindQt4.cmake:1037 (message): Qt qmake not found! (How do I include terminal outputs or files in good ways for people to read in the comments?) – supercuteboy May 25 '14 at 14:50
  • @supercuteboy My fault. Run sudo apt-get install cmake. Then go back to step 7. – scottkosty May 25 '14 at 14:59
  • @supercuteboy Did that work? – scottkosty May 25 '14 at 19:03
  • Thank you so much, you've been a great help! cmake is already the newest version. Unfortunately it still says lyxbuild: running git clean... lyxbuild: removing previous build logs... lyxbuild: removing previous CMake build lyxbuild: creating "CMakeBuild" dir and running cmake... lyxbuild: ERROR: running cmake , when I run line (7). Containing the same error message in the log file, as I commented previously. – supercuteboy May 26 '14 at 14:54
  • Trying to figure out the message and reading the "install" file in the repo folder let's me guess that I'll need qt libraries. I'm a little bit overwhelmed by what I should install, though. It says that qt4 and qt4-devel packages should be of the same version. On the QT website I can download version 5.3. Is the newer version recommended? In the Software center, I can download QT Creator, I'm not looking for an IDE, but is it still what I'm looking for, including the necessary libraries? – supercuteboy May 26 '14 at 15:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.