The tabularx package with new version 2014/04/22 v2.09 produces errors with the following code which compiled without errors before:








I do need \myfooA and \myfooB for my application, so I can't use \tabularx inside the environment definition directly (which would work with the new tabularx version).

How do I have to change \myfooA and \myfooB to work with \tabularx 2.09 ?

Addendum: Here is a MWE for the application which stopped to work:




\begin{tcolorbox}[tabularx={X},title=My table]


Update: The problem was solved by David Carlisle with tabularx v2.10

  • 2
    can you log that at latex-project.org/bugs.html (I'll put a workaround here in a bit but it would be good to log it anyway) – David Carlisle May 12 '14 at 10:39
  • As mentioned in the documentation of tabularx, \endtabularx must not be inside a pair of {}. Thus, {\myFooA} works, but {\myFooB} needs to be replaced: \newenvironment{myfoo}{\myfooA}{\endtabularx}. I guess, this is no help, but at least, it is reported on page 4 of the manual. – LaRiFaRi May 12 '14 at 10:43
  • @LaRiFaRi No: the documentation implies this should work and it used to work, so probably, it should work:-( – David Carlisle May 12 '14 at 10:45
  • @DavidCarlisle Sorry, I got that wrong then... Me and English...@Thomas, maybe you report, that the doc is still in version 2.07, as well. Maybe just a typo. – LaRiFaRi May 12 '14 at 10:47
  • 1
    @LaRiFaRi not completely wrong but... (see my answer:-) – David Carlisle May 12 '14 at 11:15

As LariFari indicated it required an optimistic reading of the documentation to suggest that it should have worked before, or that it works now, but it did work before, so I'm inclined to think it's a bug that it doesn't work in tabularx 2.09.

latex/required/tools has been updated on ctan with tabularx 2.10 which once again allows this usage.

I'm deleting the workaround initially posted here as it was only needed for a few days, and was not that robust.

  • Is it wrong to be tempted to say: WTF?! :D – yo' May 12 '14 at 11:17
  • Your workaround helps for my MWE, but I fear the problem still remains for my application. Actually, tcolorbox and tabularx stopped to work together. Here, the \myfoo macros are more complicated and your workaround seems not to help. I still looking for some MWE code which could help to analyze the problem. – Thomas F. Sturm May 12 '14 at 11:45
  • The MWE itself is short (I added it to me question now), but it involves my tcolorbox package. I still try to nail the problem down to something where you don't need tcolorbox. – Thomas F. Sturm May 12 '14 at 11:53
  • The combination of both patches works, but they produce errors themselves, if biblatex is used additionally (as written by email). – Thomas F. Sturm May 12 '14 at 13:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.