5

I have a problem with calling the makeglossaries script. Here is a MWE:

% !TeX program = xelatex
% !TeX encoding = utf-8
% !TeX spellcheck = ru_RU

\documentclass[12pt, a4paper]{article}

\usepackage{polyglossia}
\setdefaultlanguage{russian}
\setmainfont[Ligatures=TeX]{Times New Roman}

\usepackage[xindy]{glossaries}
\makeglossaries

\begin{document}

\newacronym{exm}{123}{Пример} % russian acronym

Штука называется \gls{exm}. % some russian text

\printglossaries

\end{document}

System: Windows 8, TeX Live 2013 (up to date), TeXstudio as IDE. The first compile run is fine - I get .glo .glsdefs and .xdy files. When I run makeglossaries script after, I receive the following log with error:

 ERROR: "A" does not name a letter group in
 (DEFINE-LETTER-GROUP "glsnumbers" :PREFIXES
 ("0" "1" "2" "3" "4" "5" "6" "7" "8" "9") :BEFORE "A")

 *** Unable to execute: '"xindy"  -L russian -C utf8 -I xindy -M "temp" -t "temp.glg" -o "temp.gls" "temp.glo"' ***

 Failed with error code 1.

 Status report:

 Opening logfile "temp.glg" (done)
 Reading indexstyle...
 Loading module "0tI0EhWrtr"...
 Loading module "lang/russian/utf8-lang.xdy"...
 Loading module "lang/russian/utf8.xdy"...
 Finished loading module "lang/russian/utf8.xdy".
 Finished loading module "lang/russian/utf8-lang.xdy".
 Loading module "temp.xdy"...
 Loading module "tex.xdy"...
 Finished loading module "tex.xdy".

 Error in line 426:


 ; additional letter groups

 (define-letter-group "glsnumbers"
    :prefixes ("0" "1" "2" "3" "4" "5" "6" "7" "8" "9")
    :before "A")
 ERROR: "A" does not name a letter group in
 (DEFINE-LETTER-GROUP "glsnumbers" :PREFIXES
  ("0" "1" "2" "3" "4" "5" "6" "7" "8" "9") :BEFORE "A")
 C:\Dev\TeXLive\2013\bin\win32\runscript.tlu:650: command failed with exit code 1:
 perl.exe c:/Dev/TeXLive/2013/texmf-dist/scripts/xindy/xindy.pl -L russian -C utf8 -I xindy -M "temp" -t "temp.glg" -o "temp.gls" "temp.glo"

I can't understand, why is this happenning. Any help is much appreciated.

4

If you're not using a Latin alphabet, you either need to specify the first letter of your alphabet using \GlsSetXdyFirstLetterAfterDigits (before \makeglossaries) for example:

\GlsSetXdyFirstLetterAfterDigits{А}

Or you need to use the xindy={glsnumbers=false} package option:

\usepackage[xindy={glsnumbers=false}]{glossaries}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.