1

How do I turn on page numbering with classicthesis?

I'm using TeXworks, with the pdfLaTeX setting. Here's what I have so far:

 \documentclass[10pt,letterpaper]{book}
 \usepackage{classicthesis}

 \begin{document}
 \title{Book Title}
 \author{My Name}
 \maketitle

 \tableofcontents

 \chapter{Introduction}
 \section{This Document}
 This is some text.
 \end{document}

Am I doing something wrong, or is there some other command I need to use to turn on page numbering?

  • @Sigur, that doesn't do it. Filling it with pages of lorem ipsum still leaves it without page numbers. – Joe May 12 '14 at 22:45
  • @Sigur, so what should I be doing instead? – Joe May 12 '14 at 22:55
  • Just do \documentclass{book} \usepackage{classicthesis} or \documentclass{scrbook} \usepackage{classicthesis} – Gonzalo Medina May 12 '14 at 22:55
  • @Sigur, I need it to be on letter-sized paper (8.5" x 11"). Is letterpaper the wrong way to do that? – Joe May 12 '14 at 22:57
2

The problem is with the letterpaper paper option passed to the book class.

The text height is too large and then the page number is hidden.

Since you really need that paper size, load the geometry package after classicthesis and pass the option to it.

\usepackage[letterpaper]{geometry}

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.