4

I am trying to use the author option in the \todo command provided by todonotes package. This is clearly mentioned in its manual. Following is the code snippet and the error it produces:

Snippet:

\usepackage{todonotes}
\todo[author=Doe]{This is a comment.}

Error:

! Package xkeyval Error: `author' undefined in families `todonotes'.

See the xkeyval package documentation for explanation.
1
  • No problem here when using a MWE.
    – Werner
    May 14, 2014 at 21:44

1 Answer 1

2

Probably you have to update package todonotes, from its source todonotes.dtx:

% \changes{0.9.9}{2011/10/22}{Added author option, implementation provided by 
%             Xavier Alameda-Pineda. [...]
3
  • If this is the case, then a distribution update would make this a duplicate.
    – Werner
    May 14, 2014 at 22:50
  • You are right. Installed version of todonotes is old (2011/04/21). However, I don't have the super user privileges to upgrade this package. Is there a virtual environment builder for latex like virtualenv for python or cabal (?) for haskell?
    – shoban
    May 14, 2014 at 23:35
  • 1
    @shoban: If you are using TeX Live, then you can put the updated file in the TEXMFHOME tree, usually: ~/texmf/tex/latex/todonotes/todonotes.sty. May 14, 2014 at 23:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.