I use Linux and if I go to installed fonts I can see that the 'Adobe Helvetica', for instance, is installed. I also find it if I do fc-list. But I can't use it with XeTeX. If I do \usepackage{fontspec} and \setmainfont{name_of_font} I get Metric(TFM) file or installed font not found. I can use any of the fonts found in /user/share/texmf/fonts/truetype. But I can't use the .afm fonts, neither can I open them with kfontviewer.

Thank you for the replies!

I have realised that I don't have an Adobe .ttf font, but after I run 'xlsfonts' I get a long list of Adobe Helvetica fonts. This font also appears to be installed in my system, as I checked in my System Settings. But I might have the same problem as in this forum:

can't use Helvetica

I have used 'otfinfo' and it works for .otf and .ttf files. But why can't I use it for the fonts displayed with 'xlsfonts', system fonts? There are font replacements, but why couldn't I use Helvetica? Because of copyright?

Ok...So Fontmatrix doesn't see my Adobe fonts, which appeared to be installed, because when I use Kmail to write e-mails I can choose whatever Adobe fonts I like. If I go to System Settings>>Install Fonts, I can see that my Adobe fonts are installed. Then why can't I use them with Tex or LibreOffice (as I said, I have openSUSE 11.4)?

5 Answers 5


You can always check the name of an installed font with FontMatrix.

It is better if you download the svn version and compile it from the source, as the officially released version is quite old.


Another way to do it would be to give

otfinfo -i /path/to/font


I don't know if this info is going to be helpful.

  • Thanks a bunch for this hint, FontMatrix is really great, I even found a repository which contained a newer version, as I am using openSUSE 11.4! I could clearly see all my installed fonts.
    – chimil
    Commented May 13, 2011 at 8:49
  • I still don't understand why I can't see the Adobe Family of fonts, since they appeared to be installed under System Settings>>Font Installer. I can also use them as custom fonts in applications like Kmail if I want to compose a message using Adobe Utopia, for instance.
    – chimil
    Commented May 13, 2011 at 9:43
  • @chimil I always place my fonts in /home/user/.fonts/ and fontmatrix has no problem finding them. Try to do the following: sudo updatedb then locate fontname and then load the font manually from within FontMatrix. There is also otfinfo, I updated my answer.
    – pmav99
    Commented May 13, 2011 at 10:08
  • @pmav99 Unfortunately FontMatrix does not detect my installed Adobe fonts, but I can use them when I write e-mails with the e-mail client Kmail and I also see them with fc-list. Maybe it's an error somewhere, I don't know. I also keep my .ttf fonts in /home/user/.fonts. If I run as root updatedb I get /usr/bin/find: /home/username/.gvfs: Permission denied and then usr/bin/find: warning: not following the symbolic link '/windows/C/Users/CAMIL/AppData/Local/Application Data'. I would like to try with otfinfo, but I do not know the path to the Adobe fonts.
    – chimil
    Commented May 13, 2011 at 10:35
  • @chimil How do you install the fonts? Running as root updatedb should not produce any output. This is indeed strange.
    – pmav99
    Commented May 14, 2011 at 10:28

I don't know what you mean by "amf-font". afm-files do exist, there are not fonts but only metric files (=adobe font metric). If you want to use type1 fonts, you need pfb-files.

Do you have a new tex system with luatex? Then I would suggest that you run on the command line mkluatexfontdb.exe. This will generate in one of your texmf root (TEXMF-CACHE probably) the file otfl-names.lua. Open it in an editor. It will give you a list of truetype and open type fonts luatex can find together with informations about their names and their location. Test fonts at first with lualatex, it is less picky than xelatex regarding the names in the \setmainfont-argument.

  • Yes, I misspelled it, sorry for that. I don't have windows, but I have luatex installed on my system and I'll try with an alternative linux command. I think it's more flexible than xelatex.
    – chimil
    Commented May 13, 2011 at 8:52

A related issue: I installed a ttf font and it was visible in fc-list and otfinfo, but XeLaTeX still couldn't find it. Tried everything mentioned here and elsewhere. Turned out the issue was that I needed to do

 su; chmod +r  /usr/share/fonts/foo/foo.ttf

so that the ttf file was world readable -

-rwxr----- 1 root root   [file.ttf]   before

-rwxr--r-- 1 root root    [file.ttf]  after

suddenly xelatex is happy!! Thought I'd share this in case it's hosing anyone else.


You can try to load the font by using the fontfile directly, see the fontspec manual for that. I always do that for compatability issues, as I'm working on different computers.

I had similar problems when trying to load installed fonts, in my case it was related to the fact that the name of the font as it appears in for example MS word is not always the same as the name which fontspec needs to recognize the font. For example, spaces are replaced by "-" etc. open the fontfiles to find out the true fontname.

Abit a vague description, but I can help you better when I'm behind my own computer.


For some reason, fontspec and fc-list do not use the same names when referring to fonts. In my experience, the name displayed by otfinfo -a /path/to/font/file is the one to use with fontspec. otfinfo is available in Debian/Ubuntu package lcdf-typetools.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .