0

I'm new to LaTeX so I don't even know how to phrase my question to search for it!

I am making lecture slides for a course. I use \pause before pretty much every bullet point so we can go over each point one by one. However, this makes each bullet point into a new slide, so a 20 frame presentation quickly becomes a 50+ slide PDF document. For the purposes of posting the lecture slides on the course website so students can study them later, I would like a version of the PDF which only has the frames (ie all the bulletpoints, no frames that are blank or just have the first few bullets). I could do this by removing/commenting out all the \pause and creating a second document, but I'm wondering if there's a better way?

Related: is there a way to put slide numbers (by frame, not by bullet point) on fancyslides? This:

\setbeamertemplate{footline}[page number]

doesn't work.


Here's an example of my document (which uses fancyslides.cls):

\documentclass[handout]{fancyslides}
\usetheme{default} 
\setbeamertemplate{navigation symbols}{} 
\setbeamercolor{structure}{fg=\yourowntexcol} 
\setbeamercolor{normal text}{fg=\yourowntexcol} 
\newcommand{\structureopacity}{0.80} 
\newcommand{\strcolor}{blue} 
\newcommand{\yourowntexcol}{white} 

\begin{document}
\begin{frame}
{\color{blue}\huge Slide title}
\itemized{
\pause
\item bullet points 
\pause
\item shown one by one
\pause
\item one frame, four slides
}
\end{frame}
\end{document}

[handout] doesn't seem to do anything on fancyslides. I suspect my footer page number issue has to do with the fact that my font color and background color are white?

3
  • handout doesn't work because you're using fancyslides class which is based on beamer class but doesn't have all its features.
    – Ignasi
    May 15, 2014 at 21:46
  • Okay, that's what I suspected, thanks. Perhaps it's just easier to find/replace all the \pause with %\pause. Any suggestions on getting a slide count or other progress bar?
    – wugology
    May 15, 2014 at 23:02
  • Forget my previous comment. facyslides.cls is declared without options and only uses LoadClass{beamer} without any option. Therefore when \documentclass[handout]{fancyslides} is written nothing happens with handout. If you change LoadClass{beamer} to LoadClass[handout]{beamer} inside fancyslides.cls you'll get a handout document. Although I recommend to rephrase your question (or make a new one) because I'm sure there exist better solutions. For the page numbers add \useoutertheme{infolines} as a possible solution.
    – Ignasi
    May 16, 2014 at 6:18

3 Answers 3

1

Without changing fancyslides.cls, your main document should start like this:

\PassOptionsToClass{handout}{beamer}
\documentclass{fancyslides}

...
1

[tricky part stolen from AlexG's answer, so please accept his]

You could use the handout option of the beamer class. But as AlexG showed in his answer, this only works with a trick:

\PassOptionsToClass{handout}{beamer}
\documentclass{fancyslides}

\begin{document}

    \begin{frame}

        \begin{itemize}
            \item A.\pause
            \item B.
        \end{itemize}

    \end{frame}

\end{document}
3
0

fancyslides.cls starts with

\NeedsTeXFormat{LaTeX2e}
\ProvidesClass{fancyslides}[2013/04/23 my custom beamer slides class]
\LoadClass{beamer}

This means that fancyslides doesn't have any declared option and that in case any beamer option is declared (\documentclass[handout]{fancyslides}), the option won't be passed to beamer.

A possible solution could be change third in fancyslides.cls line to \LoadClassWithOptions{beamer}. This way all beamer options declared in your .tex file will be applied to beamer.cls.


If you need page numbers add \useoutertheme{infolines} (or any other theme which shows frame numbers) to your preamble.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .