2

I've tried recompiling some complex documents meant for pdfLaTeX using XeLaTeX. After a few fixes and \ifxetex in the preamble (regarding input, hyperref and font encodings), it went through... but for some reason the newly produced document was 117 pages long instead of the original 115!

The reason is that a blank double page (well, blank except for running headers) is inserted between chapter 3 and 4.

Obviously, this is something difficult to reproduce - it did not occur between all chapters, and it possibly depends on the height of the last page.

Does this resemble some known phenomenon?

5
  • 1
    It looks as if you have something invisible after the equation which moves to the next page. If you can't find what's responsable: Try \enlargethispage{2\baselineskip} on this page. May 10, 2011 at 7:34
  • 1
    It was a \index command. It looks like having a \index command after a displayed equation creates something that takes up vertical space. Moving it at the end of a text paragraph solved the issue. Now why it does it with xelatex and not pdflatex remains a mystery; it may be related to hyperref. May 10, 2011 at 8:52
  • Compare the documents: The pages are different (which is not surprising as different fonts are use and other things can differ too). The xelatex page is longer, probably just long enough to move the index to the next page.possible that the May 10, 2011 at 10:56
  • @Ulrike I'd re-write your comment as an answer with the brief explanation given above so this question can be closed.
    – Edd
    May 10, 2011 at 11:06
  • \index creates a "wotsit" node in the output list. it would seem that xetex plays slightly different with wotsits in this case (they're notorious for producing odd effects). my guess would be that your index command got detached from the rest of the text. May 10, 2011 at 11:36

1 Answer 1

3

(Based on the comments from Ulrike Fischer and monniaux)

It turned out that an \index command after a displayed equation created additional vertical space, which effected the blank pages. Moving the command to the end of a text paragraph solved the issue. A possible reason for why this behaviour only occured with XeLaTeX is that different fonts were used and the XeLaTeX page was longer, probably just long enough to move the \index command to the next page.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.