10

I'm just trying to put a "£" sign in my document, but I can't get it to work.

My packages:

\usepackage[math]{iwona}         
\usepackage{amsmath,amsfonts}
\usepackage{graphicx}
\usepackage{algorithm,algorithmic}
\usepackage{xspace}
\usepackage{subfigure}
\usepackage{url}
\usepackage{lscape}
\usepackage{listings}

\pounds and \textsterling both produce a dollar sign ("$"). I'm using pdflatex.

  • 2
    Both work for me, i.e produce £. Please add a minimal working example (MWE) that illustrates your problem. And please don't reference your title in the body. Also "doesn't work" is not very meaningful. Do they really produce a $ sign? – Martin Scharrer May 10 '11 at 10:08
18

As described in I've just been asked to write a minimal example, what is that? in such cases it is best to remove half of the used packages until the error disappears to track down the package which causes it. In your case the error seems to be caused by the iwona font. The wrong sign seems to be caused by the wrong font encoding. You should use \usepackage[T1]{fontenc} together with iwona to avoid such things.

This works:

\documentclass{article}

\usepackage[T1]{fontenc}
\usepackage[math]{iwona}
%\usepackage{amsmath,amsfonts}
%\usepackage{graphicx}
%\usepackage{algorithm,algorithmic}
%\usepackage{xspace}
%\usepackage{subfigure}
%\usepackage{url}
%\usepackage{lscape}
%\usepackage{listings}

\begin{document}

\pounds

\textsterling

\end{document}
| improve this answer | |
1

iwona does have a £ sterling sign. (for example 0xbf in the t1 encoding tables). however, £ sterling in ot1 encoding is a booby-trap: in roman font, the relevant character produces $, in italics it produces £.

i don't know what iwona thinks of as its default encoding, but i would expect that \usepackage[T1]{fontenc} would solve the problem.

no doubt there are other encodings that will achieve this, but t1 seems ok

| improve this answer | |
1

This has worked for me:

\usepackage[T1]{fontenc}
\textsterling
| improve this answer | |
0

The following command worked for me:

$\pounds$
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.