0

I'd like to replace the URW-Garamond in my document with Adobe Garamond.

I got the 6 pfb- and pfm-files and couldn't find a way to install it for MikTex.

  • Use Walter Schmidt’s support files: ctan.org/tex-archive/fonts/psfonts/w-a-schmidt – Thérèse May 16 '14 at 15:09
  • 1
    Or compile with Xe/LuaLaTeX: if they're installed as system fonts, just add \setmainfont{Adobe Gramond Pro} and compile (however, do not load inputenc nor fontenc. – Bernard May 16 '14 at 15:14
  • @Bernard I’ve never managed to use pfb files with fontspec; I thought that support for them was a plan for the future. Is there a way to get them working now? – Thérèse May 16 '14 at 15:25
  • Sorry! I thought you had the .otf files… – Bernard May 16 '14 at 15:47
  • 1
    This doesn't answer your question directly, by have you considered using ebgaramond? – Brent.Longborough May 16 '14 at 18:30
2

(Almost) all necessary instructions are given at the above-mentioned link. What you have to do is to download the pad.txt and pad.zip files. Unzip the contents of pad.zip at the root of a LocalTeXMF tree. If you do not have one yet, create one first wih MiKTeX Settings (Roots tab) (click on the Add button for this, see image below). Do not unzip in MiKTeX 2.9. Your Local TeXMF tree must be independent from MiKTeX 2.9, else its contents may be deleted on updates.

Then, in your LocalTeXMF\fontsdirectory, create a type1 directory and copy the pfbs in it, renaming them as indicated in pad.map; do the same for the pfms (actually, I think these are not really necessary, as TeX uses the tfms).

Last step: make your system aware of all the stuff. Refresh the FNBD (via MiKTeX Settings, General tab). And last — not least, make dvips know where to grab the real fonts: write in your personal updmap.cfg the line : Map pad.map, and run from the console: updmap --verbose. This will the fonts be mentioned in psfonts.map and some other files of the sort, that dvips, pdflatex, dvipdfm, &c. read to find type 1 fonts.

enter image description here

enter image description here

  • I mistyped the file extensions: I got the afm and pfb files. I created a localtexmf and added it to miktex options. I extracted the pad.zip in this directory and added the renamed afm and pfb-files, refreshed the FNDB, added pad.map to updmap and tried to include the files by \usepackage{xagaramon} but it doesn't work. What did I do wrong? – Moldevort May 16 '14 at 17:13
  • You don't say you ran updmap from the command line. If you didn't, they don't appear in dvips.map and the like, so the dvips, pdflatex, &c., can't find the pfbs. You can check the contents of these files: they're located in C:\Users\Your_User_Name\AppData\Local\MiKTeX\2.9\dvips\config. – Bernard May 16 '14 at 18:00
  • Oops! I mistyped the name of the file: it's psfonts.map, not dvips.map. – Bernard May 16 '14 at 18:08
  • I ran initexmf --edit-config-file updmap inserted Map pad.map, saved and ran initexmf --mkmaps like it's told in MikTeX manual. Furthermore I opened updmap.cfg, added Map pad.map and ran updmap --verbose. Nothing worked. – Moldevort May 16 '14 at 20:18
  • Did you check the contents of psfonts.map? You should find there padr8r and its friends referred to. – Bernard May 16 '14 at 21:05
0

Just found a solution.

Unlike agaramon.txt says I had to use

\usepackage{xgaramon} AND \usepackage[T1]{fontenc}

  • I didn't even think of asking whether you had loaded fontenc:)! – Bernard May 17 '14 at 0:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.