18

I am trying to get my TeX document to build. I know this works because I've done it on another system, but I recently put Lubuntu on my Linux partition, so everything is new again.

I've installed Texmaker as well as texlive and texlive-latex-extra and a few other related LaTeX packages. elsarticle.cls is supposed to be part of texlive-latex-extra but when I quick build my document I still get

! LaTeX Error: File `elsarticle.cls' not found.

Is there something I have to do to tell Texmaker that I've installed extra packages, and that it can look for elsarticle.cls in texlive-latex-extra? How do I fix this?

Additional info: here are screenshots of my Texmaker settings. Please let me know if I should include anything else.

  • Welcome to TeX.SE! What does kpsewhich elsarticle.cls give you? – Mico May 20 '14 at 5:57
  • @Mico Nothing. A blank line. – agampersand May 20 '14 at 5:58
  • In that case elsarticle.cls was not installed in a folder that's searched by your TeX distribution. (Maybe it wasn't installed at all...) Try downloading the basic files from the CTAN page and running the file elsarticle.ins through LaTeX to create elsarticle.cls. – Mico May 20 '14 at 6:00
  • 1
    After installing the files, did you update the filename database of your TeX distribution? Hint: texhash might do the job.) – Mico May 20 '14 at 6:22
  • 1
    for a test copy the elsarticle.cls in your documents directory. Did it run without a problem? – user2478 May 20 '14 at 7:05
32

elsarticle is not included in texlive-latex-extra http://packages.ubuntu.com/trusty/all/texlive-latex-extra/filelist, but in texlive-publishers packages http://packages.ubuntu.com/trusty/all/texlive-publishers/filelist. So, you need to install it first. Run this command on terminal

sudo apt-get install texlive-publishers

and then try compile your document again.

0

Installing Texlive-Science solved the problem. Try sudo apt install texlive-science

  • Please see that this question is 6 years old. Your answer may be valid for a current version of TeX Live, but it may not valid for an old version six years ago ... Please add your used TeX Live version number (simply copy the first line of a resulting *.log file to your answer) ... – Mensch Oct 11 at 20:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.