3

Is there any possiblity in biblatex to deactivate the ibidtrackerin footnotes only? I'm quite new to biblatex and have found no solution for this problem yet.

I'm using biblatex with the authoryear-icomp citestyle so my quotes usually are in the main text [example: TEXTTEXT (Elden 1998: 73) TEXTTEXT (Ibid.: 28)]. But I also have footnotes (I'm using the command \footnote) to add additional information and quotes. This currently looks like this: "FOOTNOTETEXTFOOTNOTETEXT (Ibid.: 39)" but I would like to have "FOOTNOTETEXTFOOTNOTETEXT (Elden 1998: 39)".

So would like the ibidtracker to work only for the quotes in the main text but not in the footnotes.

Many thanks for your time and any help!

My current settings:

\documentclass [paper=a4, DIV10, fontsize=11pt, headsepline, headings=small, bibliography=totoc, numbers=endperiod] {scrreprt}

\usepackage[applemac]{inputenc}
\usepackage[english, ngerman]{babel}
\usepackage[autostyle,german=quotes]{csquotes}
\usepackage{lmodern} 
\usepackage[T1]{fontenc}
\usepackage{rotating}
\usepackage[obeyspaces]{url}
\usepackage{xcolor}

\usepackage{tabularx}
\usepackage{array}
\usepackage{booktabs}
\usepackage{caption}
\usepackage{chngcntr}
\counterwithout{table}{chapter}

\usepackage[left=2.5cm,right=2.5cm,top=2cm,bottom=2cm,includeheadfoot]{geometry}
\usepackage{setspace}
\setlength{\parindent}{1em}
\onehalfspacing

\addtokomafont{partentry}{\centering}
\setkomafont{partentrypagenumber}{\color{white}}

\deffootnote{1em}{1em}{\textsuperscript{\thefootnotemark\ }}
\usepackage{chngcntr}
\counterwithout{footnote}{chapter}

\usepackage{epigraph}
\setlength{\epigraphwidth}{.5\textwidth}
\setlength{\epigraphrule}{0pt}
\renewcommand{\textflush}{flushepinormal}

\usepackage[automark]{scrpage2}
\setlength{\headsep}{12mm}

\usepackage[style=authoryear, citestyle=authoryear-icomp, maxnames=2, sorting=nyt, backend=biber, dashed=false, isbn=false, uniquename=false]{biblatex}
3

By default the ibidtracker is already keeping separate track of citations in text and in footnotes. If you just want it to keep track of those in text, then you can modify the coding set-up of biblatex to define a new ibidtracker option textonly:

Text:

Sample text part

Footnotes:

Sample footnotes

\documentclass{article}

\makeatletter
\def\blx@opt@ibidtracker@textonly{%
  \let\blx@imc@ifciteibid\blx@ifciteibid@textonly
  \let\blx@ibidtracker\blx@ibidtracker@textonly
  \let\blx@ibidreset\blx@ibidreset@textonly
  \booltrue{citetracker}}

\def\blx@ifciteibid@textonly{%
  \ifbool{citetracker}
    {\iftoggle{blx@footnote}
       {\@secondoftwo}
       {\blx@imc@iffieldequals{entrykey}\blx@lastkey@text}}
    {\@secondoftwo}}

\def\blx@ibidtracker@textonly{%
  \ifbool{citetracker}
    {\iftoggle{blx@footnote}
       {\global\let\blx@lastkey@foot\abx@field@entrykey}
       {\global\let\blx@lastkey@text\abx@field@entrykey}}
    {}}

\def\blx@ibidreset@textonly{%
  \iftoggle{blx@footnote}
    {}
    {\global\undef\blx@lastkey@text}}

\makeatother

\usepackage[style=authoryear, citestyle=authoryear-icomp, maxnames=2,
sorting=nyt, backend=biber, dashed=false, isbn=false,
uniquename=false,ibidtracker=textonly]{biblatex}
\addbibresource{\jobname.bib}

\begin{filecontents}{\jobname.bib}
@Article{Elden,
  author =   {Elden, A.},
  title =    {Something},
  journal =  {S. Jor.},
  year =     1998
}
\end{filecontents}

\begin{document}

\cite[73]{Elden} and \cite[28]{Elden} but\footcite[52]{Elden} or
\footcite[71]{Elden} or even\footnote{\cite[20]{Elden}}.
\end{document}

The above coding is based on that for the context ibidtracker in biblatex2.sty, but when the footnote test is true, we do as little as possible.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.