9

I am using the scrbook (KOMA Script) class, as this MWE shows:

\documentclass[11pt,a5paper,twoside,BCOR=8mm,DIV=12,headings=normal,open=right]{scrbook}
\usepackage[ngerman]{babel}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}

\usepackage{chngcntr}

\begin{document}
\part{Introduction}
\chapter{Lorem ipsum}

\counterwithout{figure}{chapter}

\begin{figure}[h!]
    My figure here.
    \caption{My caption}
\end{figure}
\end{document}

It's working, by and large, with one exception: The caption reads

Abbildung 1.: My caption

Notice the superfluous dot before the colon? It's clearly due to using parts; if I stick to chapters and sections only it's formatted as intended.

Any bright ideas?

10

By default, the KOMA-Script classes will add a period at the end of sectioning numbers, float numbers etc. if a \part or \appendix command was issued. To counter this behaviour, add the class option numbers=noendperiod. See section 3.16 of the KOMA-Script manual for further details.

If you want to change the default behaviour only for figure and table captions, add the following to your preamble:

\renewcommand*{\figureformat}{%
  \figurename~\thefigure%
%  \autodot% DELETED
}
\renewcommand*{\tableformat}{%
  \tablename~\thetable%
%  \autodot% DELETED
}
  • 1
    Works like a charm! You, sir, are a gentleman and a scholar. – Ingmar May 20 '14 at 13:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.