Latex work fine till I do the last update today.

When compiling a text, document, I have an error :

article.cls not found

Samething for book and report class.

Any idea ?


closed as off-topic by Werner, user31729, egreg, karlkoeller, Jesse May 22 '14 at 20:39

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Did you compile mid-update? – Werner May 22 '14 at 3:52
  • What do you mean by mid-update – Sara May 22 '14 at 3:54
  • 1
    While MiKTeX is updating, if you compile, the hash file is being updated, which will make nothing work. Perhaps, rerun the Refresh FNDB from the MiKTeX Package Manager menu and try again after it is complete. – Werner May 22 '14 at 3:56
  • I Refresh FNDB and still not work. I did not compile during the update. – Sara May 22 '14 at 3:59
  • 4
    This question appears to be off-topic because a re-install resolved the problem. – Werner May 22 '14 at 20:16

It's not exactly the same: it just happened to me but it did not seem to be a problem with a .tpm file. Actually, for some reason, last update deleted the ltxbase package. So it was highly unlikely you'd be able to compile whatever.

However, ltxbase.tar.lzma still exists in MiKTeX repository. What I did was to download it from, say, Dante. Then I untar-lzma'ed the file (7-zip can do it), resulting in a texmf directory. All I had to do was to copy the contents of this directory at the root of MiKTeX 2.9 and refresh the FNDB via MiKTeX Settings.

  • Did you make a bug report? – Ulrike Fischer May 22 '14 at 8:32
  • Well, I do not know how to do it. I'll try to find out today. – Bernard May 22 '14 at 8:35
  • @Ulrike Fischer: bug report made today. – Bernard May 23 '14 at 14:09
  • You are a bit late. The problem has been resolved. – Ulrike Fischer May 23 '14 at 14:13

the problem is an error in miktex, is equal to the error given in MikTeX problem after last update.

happens to me and it was the same for the update.

  • If it's the same, then we can close it as a duplicate, right? – Werner May 22 '14 at 7:02
  • 1
    @Werner: It doesn't sound as the same error. The error yesterday affected the package manager and gave a parsing error. It didn't affected the file search. – Ulrike Fischer May 22 '14 at 8:17

Not the answer you're looking for? Browse other questions tagged or ask your own question.