10

When I am using hyperref, the package puts underline to the journal title in my references. How can I get rid of this underline?

A similar question is asked here: Turning underlines OFF in hyperref

However, I am using pdflatex.

UPDATE: MWE upon request

\documentclass{report}

\usepackage{apalike}
\bibliographystyle{apalike}
\let\bibhang\relax
\usepackage{natbib} % reference manager

\usepackage{ulem} %to strike the words

\usepackage{hyperref}
\usepackage{cleveref}

\begin{document}

This a citation \citep{Goossens:1994}

\bibliography{biblo}

\end{document}

biblo.bib is:

@Book{Goossens:1994,
author    = {Michel Goossens and Frank Mittelbach and Alexander Samarin},
title     = {The {\LaTeX} Companion},
publisher = {Addison-Wesley},
address   = {Reading Massachusetts},
year      = 1994}

Appearently, ulem is culprit, but I am still not sure how to remove underline, while I need ulem for other stuff.

14

Simply load ulem with the option normalem, otherwise all \emphasized words will be underlined.

MWE:

\documentclass{report}

\usepackage{apalike}
\bibliographystyle{apalike}
\let\bibhang\relax
\usepackage{natbib} % reference manager

\usepackage[normalem]{ulem} %to strike the words

\usepackage{hyperref}
\usepackage{cleveref}

\begin{document}

This a citation \citep{Goossens:1994}

\bibliography{biblo}

\end{document} 

Output:

enter image description here

Instead, if you want \emph to underline your text, don't use that option, but issue the command \normalem just before your bibliography, as in the folllowing example:

\documentclass{report}

\usepackage{apalike}
\bibliographystyle{apalike}
\let\bibhang\relax
\usepackage{natbib} % reference manager

\usepackage{ulem} %to strike the words

\usepackage{hyperref}
\usepackage{cleveref}

\begin{document}
\emph{Underlined text}

This a citation \citep{Goossens:1994}

\normalem
\bibliography{biblo}

\end{document} 
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.