1

i want to use a movie in my beamer class presentation. I've worked now a lot in order to create a minimal working example but i failed all the time. I've also read a lot of threads here and elsewhere.

I'm using Ubuntu 12.04, Texlive 2012/Debian, Adobe Reader 9.4.1 . I want to include a video and tried using .mp4 and .mov.

Compiling with no problems. Under Ubuntu: When I start the Adobe Reader in Fullscreeen, changing to the slide with the video lets adobe loads somehow, but nothing happens. Also under Windows, the Reader loads somehow, but does not play the video. Does somebody has an idea?

And is there maybe another way of including videos in a beamer class presentation in a way that the success of the presentation is not dependent on the Reader (e.g. Okular)? Thanks a lot for your help. Here my Example

\documentclass[slidestop,compress,10pt,xcolor=dvipsnames]{beamer}
\usepackage{media9}
\begin{document}

\frame{
\titlepage
}

\frame
{
\includemedia[
label=some_dice,
width=5cm,
addresource=output.mp4, 
transparent, 
activate=pageopen,
flashvars={
source=output.mp4
&loop=true % loop video
&scaleMode=letterbox 
}
]{}{VPlayer.swf}

}

\end{document} 
1

Most likely a video encoding issue, if the example above works using random.mp4 from the media9 package. Recent versions of ffmpeg were reported to produce faulty MP4 files.

The following workaround worked for me (starting from a numbered PNG sequence file-0.png, file-1.png, ..., file-99.png):

# high quality MPG with little compression at 25 frames per second
ffmpeg -i file-%d.png -sameq -r 25 video.mpg

# recoding into MP4/H.264
ffmpeg -i video.mpg -c:v libx264 -g 25 -r 25 video.mp4
  • Using the random.mp4 from the media9 package gives the same result: just white screen and no video. – Thomas May 22 '14 at 10:14
  • @Thomas: Even in AR under Windows? For AR-X and XI the FlashPlayer plugin for Firefox (not the ActiveX variant for IE) must be installed separately. – AlexG May 22 '14 at 10:32
  • @Thomas:AR-9.4.1 for Linux may not play the video if run in a x86_64 environment – AlexG May 22 '14 at 10:35
  • I just found out, downloading the media9 Package, v0.43 documentation Can be found here and opening it with AR at ubuntu, AR crashes during a presentation when i go to slide 18 where the first animation is supposed to show up. Indicating it is acutally a problem of AR? – Thomas May 22 '14 at 13:32
  • @Thomas. Examples on p. 18 don't work in Linux anyway. What happens if you directly go to page 26? The video and sound examples should run in Linux AR-9.4.1. They use VPlayer9.swf and APlayer9.swf. – AlexG May 22 '14 at 13:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.