1

This question already has an answer here:

Writing in texmaker these lines

(the mount heigh is $1200m$).
we saw it in \ref{chapter1}.
width=6.02099737532808in           (inside tikzpicture environment)

all the dots (fullstop) get replaced by this symbol

strange symbol

When I compile the document then it behaves like a dot, and get rendered as a dot/fullstop. Even if it's not a problem thou, I would like to understand what this symbol means and if it has some reason to exist...

Anyone has a clue?

EDIT:

Compilable version:

\documentclass{book}
\begin{document}
(the mount heigh is $1200m$).
we saw it in \ref{chapter1}.
\end{document}

marked as duplicate by egreg, Malipivo, Joseph Wright May 22 '14 at 15:09

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • As I said there is no error, nor wrong output during compilation. I add a compilable version, but this behaviour is only visible in the editor and not in the output. I guess this is only visible with TexMaker. – Luca Amerio May 22 '14 at 14:23
  • Go to Preferences >> Editor and check what the editor font encoding is. Is it UTF-8 or something else? – jub0bs May 22 '14 at 14:23
  • UTF-8. I'm running on a Mac – Luca Amerio May 22 '14 at 14:26
  • 2
    Found the solution here tex.stackexchange.com/questions/154500/… I called it "strange symbol" and "fullstop" so didn't find that while looking through existing answers. Sorry – Luca Amerio May 22 '14 at 14:31
1

Use a monospaced font for the editor like Lucida Sans Typewriter or DejaVu Sans Mono

  • Monospaced ... thanks. Monotype is an old printing maschine – user2478 May 22 '14 at 15:19
  • I encountered teletype. – user4686 May 22 '14 at 15:25
0

Changing the font to Apple Braille in texmaker editor fixes the problem.

Texmaker > Preferences > Editor > Editor font family > Apple Braille

Not the answer you're looking for? Browse other questions tagged or ask your own question.