28

(Summary: tmlgr was not working in a typical manual (non-apt) install of TeXLive in Ubuntu.)

In Kubuntu, I used install-tl-unx.tar.gz, and install-tl --gui=text to make a basic install. That is, I prefer not to use the full install, and get the few packages I need as I need them (parskip, etc.).

I put

PATH=/usr/local/texlive/bin/x86_64-linux:$PATH; export PATH 

in my ~/.profile (and reboot) so that my Linux can find latex and tlmgr.

Here are the type of errors I get when trying to use tlmgr.

(running on Debian, switching to user mode!)                                          
cannot setup TLPDB in /root/texmf at /usr/bin/tlmgr line 5336.  

Googling for this leads to a suggestion to use

tlmgr init-usertree 

Then I get

sudo tlmgr install parskip.sty
(running on Debian, switching to user mode!)
/usr/bin/tlmgr: Initialization failed (in setup_unix_one):
/usr/bin/tlmgr: could not find a usable xzdec.
/usr/bin/tlmgr: Please install xzdec and try again.
Couldn't set up the necessary programs.
Installation of packages is not supported.
Please report to texlive@tug.org.
tlmgr: exiting unsuccessfully (status 1).

Okay, drum roll for the answer... as simply formulating the question carefully pointed me to an obvious next step, which seems to be the "terminal" of my problem.

  • My solution now may be to side-step this Ubuntu/ TeX Live mess and keep a texmf directory backedup with the additional packages I need, downloaded manually from CTAN. – Brady Trainor Aug 30 '14 at 1:23
44

So, what doesn't work is

tlmgr install xzdec

Why would it? tlmgr is not working yet. So, as I'm writing the question, I realize I might try

sudo apt-get install xzdec

and it worked! What .tex document would once not compile, now does!

(Well anyways, I next tried sudo tlmgr install parskip, and then the TeX document compiled, but I'm hoping that on-the-fly package installing is now working.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.