I have been working during the last year in my thesis with LyX. Yesterday I opened my file in another computer and when I open it in mine this error appears:

enter image description here

What can I do to solve this issue?

Thank you very much in advance. It is very urgent because I will submit my thesis in a few weeks.


  • Have you tried opening the document with a plain tex editor? If it looks fine there, you can try re-saving it and then opening it with Lyx. – dustin May 27 '14 at 15:51
  • Welcome to TeX.SX! Looks to be a temporary file that is corrupted, but safety first, so do you have backups of your thesis? (You should.) Moving on, does it still open in the other computer? Does that computer also have LyX 2.0.x, or does it use LyX 2.1? If you open the .lyx file in a text editor one of the first lines will tell you which version of LyX created the file. – Torbjørn T. May 27 '14 at 15:54
  • You might have run into a nasty LyX bug: lyx.org/trac/ticket/9049 However I notice that you're using 2.0.6. It could also be a lyx2lyx issue if the other computer you used has LyX 2.1. Please upgrade LyX to 2.1 and try to open the file again. – scottkosty May 27 '14 at 20:49
  • Note: If by any chance for any reason you do not have a backup of the file, make a copy of the file before you do anything else. Before you try opening it in anything at all. Only work with the copy you make. However, you surely have backups of your thesis, right? (Not only you should have backups - you should make sure other people have backups, too e.g. leave one with your advisor or send one to your grandmother or whatever.) – cfr May 28 '14 at 2:05

I had the same issue. The file was made with LyX 2.1 and I was trying to open it with LyX 2.0. Updating my version of LyX solved the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.