1

I am having issue with generating references using TeXworks. Bibtex does not generate .bbl file, and the citation in the pdf appears only with [?].

Here is my pdflatex code:

\documentclass{article}
\begin{document}
As is discussed in \cite{power}
\bibliographystyle{plain}
\bibliography{ref}
\end{document}

Here is my bibtex code with only one entry:

@misc{power,
title = {Compressive Sensing: The Big Picture},
author = {Carron, I.},
year = 2013,
howpublished = {\url{ https://sites.google.com/site/igorcarron2/cs#reconstruction}}
}

I compiled them in this manner: pdflatex, bibtex, pdflatex, pdflatex. But the bibliography does not show and the citation is only [?]. What seems suspicious is that no .bbl file is generated although bibtex has been run many times. Can anyone help me?

  • 4
    Do you get any warning(s) after running bibtex or in any other stage of the compilation process? – Gonzalo Medina May 28 '14 at 1:28
  • Is your bibtex code in a file named ref.bib? Where is that file? Also, the sequence you probably need is pdflatex, bibtex, pdflatex, pdflatex (2 runs of pdflatex following bibtex). But that wouldn't explain the lack of the bbl. – cfr May 28 '14 at 1:48
  • No. bibtex runs smoothly without any warning. This is another point that I am confused: when I add some wrong codes (like drop a "}"), it still runs well without warning. – Fred May 28 '14 at 1:52
  • Yes, the bibtex code is in ref.bib, which is in the same file with the pdflatex file. I am sorry for the typo in the sequence. I did exactly the sequence you suggested. – Fred May 28 '14 at 1:56
1

This is an attempt. Possible source of errors could be that your bib file was saved as ref.bib.tex and forgot to load hyperref package. Run the file via TeXworks either

PdfLaTeX+MakeIndeX+BibTeX  or XeLaTeX+MakeIndeX+BibTeX

Just in case for the commands wasn't set, this is what is set in my TeXworks and got the results.

Edit -> Preference --> Typesetting-->Tool Configuration, Use + to add at the processing tools window.

Name      PdfLaTeX+MakeIndex+BibTeX
Program   texify.exe
Argument  --pdf
          --tex-option=$synctexoption
          $fullname


Name      XeLaTeX+MakeIndeX+BibTeX
Program   texify.exe
Argument  --pdf
          --engin=xetex
          $fullname

enter image description here

Code

\documentclass{article}
\usepackage{hyperref}
\begin{document}
As is discussed in \cite{power}
\bibliographystyle{plain}
\bibliography{ref}
\end{document}

and ref.bib has

@misc{power,
title = {Compressive Sensing: The Big Picture},
author = {Carron, I.},
year = 2013,
howpublished = {\url{ https://sites.google.com/site/igorcarron2/cs#reconstruction}}
}

and .bbl generated

\begin{thebibliography}{1}

\bibitem{power}
I.~Carron.
\newblock Compressive sensing: The big picture, 2013.
\newblock \url{ https://sites.google.com/site/igorcarron2/cs#reconstruction}.

\end{thebibliography}
  • Thanks for your suggestion. But there is a warning when I runs MakeIndex: Couldn't find input index file go nor go.idx. ("go" is the main file that I am running) – Fred May 28 '14 at 2:31
  • @Fred -- Maybe the command was not properly set. I have added my TeXworks system that run your case for your reference. Hope this will help. See the update thanks. – Jesse May 28 '14 at 2:50
0

I noticed the same thing that TexWorks was not outputting a .bbl file even when running: PdfLaTeX+MakeIndeX+BibTeX. The reason turned out to be a --clean option in the tool configuration. As an earlier answer indicated, go to:

Edit --> Preference --> Typesetting-->Tool Configuration

and remove the --clean option for this command sequence. When I did that, a number of intermediate files were left after compiling my LaTeX file including the .bbl file which is what I needed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.