1

I am writing a conference paper with a preamble like this.

\documentclass[conference, 10pt, letterpaper, twoside, twocolumn, final]{IEEEtran}

The conference has a page limit of five pages. After a lot of edits and scissor outs, I can finally fit it within the limit, but very tightly. I am at a condition where adding a single word will take it to the sixth page. The problem is when compiling (with Kile and TeX Live on Linux platform) the output produces an empty sixth page. How to get rid of it?

  • Please help us to help you and add a minimal working example (MWE) that illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}. – user31729 May 28 '14 at 6:28
  • So page 6 is empty and you just want to exclude it? – Werner May 28 '14 at 6:42
  • Yes. I just want to exclude page 6. I could do it in the PDF itself, but for the conference I will have to give the tex file from which they will compile. I thought an MWE is not necessary since the problem is not with undesired output, but with a blank page. So the only working example can be my full tex file. – Della May 28 '14 at 7:03
3

If the last page is empty and you know your restriction, you can easily exclude it by adding the following to your document preamble:

\usepackage[-5]{pagesel}% http://ctan.org/pkg/pagesel

This will retain all pages up to (and including) page 5.

  • Thanks for your answer. I am having some weird issues I have never seen. I am having some problem with my aux file if I compile the command as it is. As advised in the CTAN documentation, I added the nonofiles option (although I don't know what that means). I can compile to dvi and ps by Alt+2 and Alt+4, but the pdf generation fails. The dvi is perfect, but the ps is faulty. Then I tried Alt+6 for pdflatex and it works. I just thought I should let others know about the pitfall. This is strange. – Della May 29 '14 at 5:32
  • @Barman: You've added \nofiles? Which CTAN documentation? – Werner May 29 '14 at 5:33
  • The documentation from the link you have given as part of your command. My command now looks like \usepackage[-5, nonofiles]{pagesel} – Della May 29 '14 at 6:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.