0

I'm writing my thesis and I'm stuck on a problem

 \usepackage[latin1]{inputenc}
 \usepackage[brazil]{babel}

 \input{./inc/Intro/intro.tex}

When compiling I get tons of "Missing $", "Missing {", "Extra }"
If I insert my text manually it works

The funny thing I just noticed is that the compiler acuses error in the main file(TCC.tex), not in the one I'm trying to input. But the lines that have "errors" are equivalent to the ones in intro.tex file

E: /Users/Rafael/Dropbox/Poli/13 Semestre/TCC/Relatório/Latex/modelo_poli/TCC.tex:3 Missing $ inserted ...ventualmente, suprir uma carência tecnoló
E: /Users/Rafael/Dropbox/Poli/13 Semestre/TCC/Relatório/Latex/modelo_poli/TCC.tex:3 Extra }, or forgotten $ ...ventualmente, suprir uma carência tecnoló
E: /Users/Rafael/Dropbox/Poli/13 Semestre/TCC/Relatório/Latex/modelo_poli/TCC.tex:4 Missing $ inserted
E: /Users/Rafael/Dropbox/Poli/13 Semestre/TCC/Relatório/Latex/modelo_poli/TCC.tex:5 Missing $ inserted ... do projeto, nosso objetivo é ter o protó
E: /Users/Rafael/Dropbox/Poli/13 Semestre/TCC/Relatório/Latex/modelo_poli/TCC.tex:5 Extra }, or forgotten $ ... do projeto, nosso objetivo é ter o protó

There is another question very similar to mine at: tabular, siunitx and input - `Extra }, or forgotten $.`

But I couldn't really bring this to my problem. I also don't understand what the solution of "using an additional column" is exactly

I also found this topic: “Missing $ inserted” in included .tex file via \input

And indeed the encoding of the files was different but now I set both to UTF-8...

Thanks!

  • why don't you use \usepackage[utf8]{inputenc} for portuguese? – Mario S. E. May 31 '14 at 19:48
  • I did and I got E: /Users/Rafael/Dropbox/Poli/13 Semestre/TCC/Relatório/Latex/modelo_poli/TCC.tex:2 Package inputenc Error: Unicode char \u8:e not set up for use with LaTeX ...chapter}{Lista de Ilustraes}{}{chapter.0} – Rafael May 31 '14 at 20:02
  • What is contained in intro.tex? – user31729 May 31 '14 at 20:40
  • Try removing accents in your folder names – Mario S. E. May 31 '14 at 20:41
  • 3
    @Rafael the specified encoding has to match the act ual encoding in the file if you chaneg from [utf8[ to [latin1] you need to save the file in the appropriate encoding. You say you set the file encoding to utf8 but your code fragment says latin1 ? – David Carlisle May 31 '14 at 21:23
1

Ok, it worked!

I did two things here:

  1. I really had to fix the encoding, but I chose Western (Windows 1252).
    I'm not pretty sure why it worked with Western and not with UTF8, but I'm using a model made by someone else so I just used his settings

  2. I took the spaces and accents from the directories and filenames

Thanks for the help everybody!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.