14

In addressing this question the first thing to note is that everything works, compiles and displays correctly on my computer. However, when I go to upload my document to arXiv.org sometimes things change. In particular, publishing URLs in a bibliography to the arXiv.org is (apparently) very difficult.

Issue 1: Bibliography not showing up at all.

Issue 1 Solved: Publishing to Arxiv using Biblatex-Biber

Issue 2: Bibliography displays urls outside the border of the document. It doesn't wrap the text of the url in a bibliography item. Again, it works fine on my computer, just not on the website arXiv.org.

Issue 2 Solved: Line breaks of long URLs in biblatex bibliography?

Issue 3: With the setup from the first two issues, I now have a new problem. If a URL wraps to a new line, like this

[5] Author. Title. PhD thesis. Place, May 2011. url: http://aaaaaaaaaaa.a
    aaaaaaa/aaaaaaa.aaaaaaaa/aaaaaaa.aaa.aaaaaa.

arXiv.org disables the hyperlink. Again, hyperlinks are not disabled and work perfectly fine on my system. But wrapped urls on arXiv.org no longer have hyperlinks. If a bibliography item looks like

[6] Author. Title. PhD thesis. Place, May 2011. DOI: aaaa.aaa/a.aaa.aa

so that it does not break, the the hyperlink stays intact.

How do I solve issue 3? I am surprised that this is not a more common issue, considering the extensive use of the arXiv.

MWE:

test.TEX

%Document Type
\documentclass[reqno]{amsart}
%Bibliography Commands
\usepackage[english]{babel}
\usepackage{csquotes}
\usepackage[style=numeric-comp,firstinits=true,backend=bibtex,%backref=true,
]{biblatex}
\bibliography{test.bib}
\DeclareFieldFormat[article,book,incollection,phdthesis,misc]{volume}{\mkbibbold{#1}}
\DeclareFieldFormat[article]{publisher}{\textnormal{#1}}
\DeclareFieldFormat[article,book,phdthesis]{title}{\mkbibemph{#1}}
\setcounter{biburlnumpenalty}{7000}
\setcounter{biburllcpenalty}{7000}
\setcounter{biburlucpenalty}{8000}
%Packages
\usepackage{amsmath}
\usepackage{amsthm}
\usepackage{amsfonts}
\usepackage{amssymb}
\usepackage{mathrsfs}
\usepackage{enumerate}
\usepackage[usenames,dvipsnames]{xcolor}
\usepackage{graphicx}
\usepackage{tikz,caption}
\usetikzlibrary{arrows,shapes,trees}
\usepackage{verbatim}
\usepackage{url}
\usepackage[hyperindex,breaklinks]{hyperref}
\hypersetup{linkcolor=blue, citecolor=red, colorlinks=true}
\usepackage{array}
\begin{document}
Reference \cite{one} and \cite{two}. 
\printbibliography
\end{document}

test.BIB

@ARTICLE{one,
url = {http://www.google.com}}
@Article{two,
url = {https://tex.stackexchange.com/questions/182523/publishing-to-arxiv-with-hyperlinks?noredirect=1#comment420451_182523}}

If you compile this on a local system it works fine. But if you try to publish this to the arXiv, it no longer has a hyperlink for the second item.

  • Hard to do much for you without a complete minimal working example (MWE) but have you tried including a file 00README.XXX with the line nohypertex? Most issues where something appears different when processed on arXiv vs locally can be fixed this way. – Lev Bishop Jun 1 '14 at 2:50
  • @LevBishop Just tried your suggestion and it didn't work either. Not sure how a minimal working example will help, since it works fine on my system and fails to work arXiv. You could just try to upload any old document. Anyway, I will add a MWE for completeness sake. – Bobby Ocean Jun 1 '14 at 4:32
  • considering the extensive use of the arXiv: remember this depends on you 'point of view'. ArXiv is big for physics but not for (say) chemistry, where sending a paper to a preprint server would prevent publication in a journal. – Joseph Wright Jun 1 '14 at 7:03
  • @JosephWright My comment had nothing to do with particular fields, where clearly different fields have different preferences. In terms of numbers of publications that arXiv receives per day, I think my comment is well justified (en.wikipedia.org/wiki/ArXiv). I only made this comment because I found it surprising that this issue had not been addressed before. About 99.99% of the time, my simple questions are answered with a quick Google search; but not this time. :-( – Bobby Ocean Jun 1 '14 at 8:33
12

With the MWE I can see that arXiv was processing your submission with latex instead of pdflatex. You can force pdflatex by including a line

\pdfoutput=1

within the first 5 lines of your submission, in which case everything seems to work. See the arXiv help on this point.

  • THANK YOU!!!!! Worked great. I don't know how I would have every figured that out. – Bobby Ocean Jun 2 '14 at 3:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.