11

When using refsegment without defernumbers, I get a warning that I should enable defernumbers. When I enable it, the numbering becomes a mess:

Issue

Specifically, the numbering of the bibliography starts at x+1 instead of 1, where x is the number of bibliography entries (unique or otherwise) typeset in all refsegments.

Weirdly, the use of, e.g., refsegment=section itself does not cause the issue. If the \printbibliography[segment=x] commands are commented-out, the numbering starts from 1 as expected.

I also tried resetnumbers in the first \printbibliography, but nothing changed.

I also posted a question here yesterday which gave rise to comments about the defernumbers issue. I am not sure whether or how the two are related.

MWE:

\documentclass{article}

\usepackage{filecontents}
\begin{filecontents}{bibliography.bib}
@Article{gob,
  title           = {I've Made a Huge Mistake},
  author          = {Bluth, Gob},
  journal         = {Journal of Magicians},
  year            = {2003},
  volume          = {1},
  number          = {1},
  pages           = {1--10},
}

@Article{michael,
  title           = {Her?},
  author          = {Bluth, Michael},
  journal         = {Sudden Valley},
  year            = {2003},
  volume          = {1},
  number          = {1},
  pages           = {1--10},
}

@Article{tobias,
  title           = {Never-nudism},
  author          = {F{\"u}nke, Tobias},
  journal         = {Blue Man Group},
  year            = {2003},
  volume          = {1},
  number          = {1},
  pages           = {1--10},
}
\end{filecontents}

\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[british]{babel}
\usepackage{csquotes}
\usepackage[%
  backend=biber,
  refsegment=section,
  defernumbers=true,
  sorting=none,
]{biblatex}
\addbibresource{bibliography.bib}

\begin{document}
\section{First section}
Check this out~\cite{gob,tobias}.
\printbibliography[heading=subbibliography,segment=1,]

\section{Second section}
Check this out~\cite{michael}.
\printbibliography[heading=subbibliography,segment=2,]

\nocite{tobias}
\printbibliography
\end{document}
  • Can you say which version of biblatex you are using? Also, what happens if you run latex again, do the numbers change? Various defernumbers bug fixes were made in fairly recent biblatex updates. – PLK Jun 1 '14 at 21:44
  • @PlK I do not know the build numbers but I use a combination of biblatex 2.9 and biber 1.9, both beta releases, downloaded from SourceForge on May 11th. If the issue has been fixed in a recent release, could you please write a short answer explaining that? Also, any idea if this issue is related to the \includeonly issue in the linked question? – sudosensei Jun 1 '14 at 21:57
  • @PLK: Also, no. The numbers do not change if I run latex again. – sudosensei Jun 1 '14 at 21:58
  • Hmm, defernumbers is quite a pain sometimes - I'll have a look at this. – PLK Jun 1 '14 at 22:07
  • For what it's worth (a hack), the numbering is correct when you exclude the last \printbibliography or if you call it as \printbibliography[resetnumbers=true]. – cslstr Jun 2 '14 at 1:29
3

This was a bug in biblatex. This should be fixed in the 3.0 DEV version on Sourceforge. There is no need to update biber - 1.9 currently works with biblatex 3.0 DEV.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.