3

I'm inserting citations with bibtex and getting an unwanted tilde before the author's names. How could I prevent this behavior?

The headers of my document are

\documentclass{sig-alternate}
\usepackage[english,spanish]{babel}
\usepackage[utf8]{inputenc}
\usepackage{hyperref}

Citation with unwanted tilde

  • 5
    You haven't given enough code to diagnose the problem. First, the sig-alternate class isn't in a standard TeXLive distribution; where does it come from. But if you can reproduce the problem with the article class, then using this class isn't part of the problem. Second, your question is a problem with the bibliography, but you don't show what methods you are using to produce it with. Please make a complete minimal document that shows the problem. It might also be helpful to paste an entry from your .bib file too (or do all entries have the same problem?). – Alan Munn Jun 2 '14 at 1:05
  • Sorry, I'm both a noob to LaTeX, MacTex and this forum. Thanks for your answer! – JPCF Jun 2 '14 at 21:31
6

The problem lies with an interaction between the sig-alternate class and the Spanish option of babel. The Spanish option of babel implements various shorthands, and you need to turn off (at least) the one for the tilde. Since you are using utf8 input, it's likely that you don't need the tilde shorthand, so you can turn it off as a package option, by adding es-notilde. If for some reason you are using the shorthands in the document, you can add

\spanishdeactivate{~}

just before your \bibliography command.

Here's a minimal working example (like the one you should have provided) which solves the problem (remove the es-notilde option to reproduce the problem).

\begin{filecontents}{\jobname.bib}

@article{Sobin1976,
    Author = {N Sobin},
    Journal = {Linguistic Inquiry},
    Pages = {726-728},
    Title = {Pragmatics of Lurking},
    Volume = {7},
    Year = {1976}}
\end{filecontents}
\documentclass{sig-alternate}
\usepackage[english,spanish,es-notilde]{babel}

\usepackage[utf8]{inputenc}
\usepackage{hyperref}
\bibliographystyle{abbrv}
\begin{document}
\cite{Sobin1976}

\bibliography{\jobname}
\end{document}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.