1

How do I use Sublime Text 3's built in package manager to install packages from ctan? I am trying to install and use matlab-prettifier in a latex document class report. I manually downloaded, compiled (for .sty) and placed matlab-prettifier unzip folder from CTAN into ~\user\me\library\texmf on my mac. For example (the following code does not work) but shows what i am trying to do:

\documentclass[12pt]{report}
\usepackage{listings} 
\usepackage{amsmath}
\usepackage[framed,numbered]{matlab-prettifier} 
\usepackage{color} %red, green, blue, yellow, cyan, magenta, black, white
\definecolor{mygreen}{RGB}{28,172,0} % color values Red, Green, Blue
\definecolor{mylilas}{RGB}{170,55,241}

\begin{document}

\lstset{language=Matlab,%
%basicstyle=\color{red},
breaklines=true,%
morekeywords={matlab2tikz},
keywordstyle=\color{blue},%
morekeywords=[2]{1}, keywordstyle=[2]{\color{black}},
identifierstyle=\color{black},%
stringstyle=\color{mylilas},
commentstyle=\color{mygreen},%
showstringspaces=false,%without this there will be a symbol in the places where there is a space
numbers=left,%
numberstyle={\tiny \color{black}},% size of the numbers
numbersep=9pt, % this defines how far the numbers are from the text
emph=[1]{for,end,break},emphstyle=[1]\color{red}, %some words to emphasise
%emph=[2]{word1,word2}, emphstyle=[2]{style},    
}

\begin{lstlisting}[style=Matlab-editor]
Po(Vo,BWc,BWs,Ro,n,LdB,Rpd) ...
= (Vo/Rpd)*(1/Ro)*(1/(BWc/BWs)*(10^((-(3+2*n)*LdB)/10)));
Po(0.0059,1.6,35,0.01,n,LdB,75)
\end{lstlisting}

\end{document}

The following code does work but not formatted as intended:

\documentclass[12pt]{report}
\usepackage{listings} 
\usepackage{amsmath} 

\begin{document}
$Po(Vo,BWc,BWs,Ro,n,LdB,Rpd) ...
= (Vo/Rpd)*(1/Ro)*(1/(BWc/BWs)*(10^((-(3+2*n)*LdB)/10)));
Po(0.0059,1.6,35,0.01,n,LdB,75)$

\end{document}
  • I don't know about Sublime Text 3. However, the path that you should use for manually installing sty files on a Mac is ~/Library/texmf/tex/latex. Create the tex/latex subdirectories if you have to. See tex.stackexchange.com/a/1138/21891 for more details. – jub0bs Jun 2 '14 at 14:56
  • Your first MWE compiles as expected and produces the desired output. What exactly do you mean by "the following code does not work"? Is matlab-prettifier.sty not found? If so, are you sure you put the .sty file where it should be? Try to put the .sty file in ~/Library/texmf/tex/latex/... – jub0bs Jun 19 '14 at 22:58