1

Last week-end, the compilation biber + xelatex worked very well.

But today I have moved my files in another place of my computer, and I can't compile any of my texts any more. Whenever I try, the citations remain undefined

I think the problem comes from my .bib file (because I haven't modified the former documents which used to work fine), but I can't find what it is.

I use this configuration :

\documentclass[12pt,a4paper]{report}
\usepackage{fontspec}
\usepackage{xunicode}
\usepackage{polyglossia}
\usepackage[maxlevel=3]{csquotes}
\usepackage{graphicx}
\usepackage[style=authoryear, language=english]{biblatex}
\setmainfont[Ligatures=TeX]{FreeSerif}
\setmainlanguage{english}
\addbibresource{mabiblio.bib}

I and get this result :

LaTeX Warning: Citation 'Dgscgc2013' on page 10 undefined on input line 125.

or this :

LaTeX Warning: Empty bibliography on input line 137.

and finally this :

 Latex failed to resolve 40 citation(s)
Latexmk: Errors, so I did not complete making targets
Collected error summary (may duplicate other messages):
  pdflatex: Command for 'pdflatex' gave return code 512
Latexmk: Use the -f option to force complete processing,
 unless error was exceeding maximum runs of latex/pdflatex.
  • Try to delete *.bbl and other files directly connected to bibtex, but not .bib file, also delete the .aux file and recompile – user31729 Jun 2 '14 at 13:30
  • I don't have a *.bbl file when I compile, it might be the problem ? – Leo Jun 2 '14 at 13:38
  • Did you run bibtex at all? – user31729 Jun 2 '14 at 13:40
  • Do you have a .blg-file? What does it say? – Ulrike Fischer Jun 2 '14 at 13:41
  • No I don't have a .blg-file. And the terminal says : Package biblatex Warning: Please (re)run Biber on the file:"The State can’t do everything any more” : Understand ing the evolution of civil defense policies in France" and rerun LaTeX afterwards. – Leo Jun 2 '14 at 13:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.