25

I'm a real novice on LaTex, having only used it previously a small amount at University but not for a while. I've decided I'd quite like to transfer my CV to the LaTex moderncv style.

I downloaded the package here http://www.ctan.org/pkg/moderncv

I use TexWorks, and I was hoping I'd just be able to open the template file from the moderncv download, compile it and edit the text to produce a nice CV.

Unfortunately, when I try to do this I get the following error:

Running ttf2pk.exe...

miktex-makepk: PK font umvs could not be created.

!pdfTeX error: pdflatex.EXE (file umvs): Font umvs at 864 not found

==> Fatal error occurred, no output PDF file produced!

texify: pdflatex failed for some reason (see log file).

So it seems to be a problem with not having a font package installed or something?! Do you know which package this is?

And how do I actually download a font package so that TexWorks knows it's installed and thus compiles the file? I've heard people talk about Miktex package installer, but I don't think I have that available, but I set up all my LaTex stuff quite a while ago, so I'm not sure...

Sorry for my very poor understanding of LaTex, I'd just like to find a way to get this moderncv package working asap. Any help would be much appreciated.

Added MWE:

\documentclass[11pt,a4paper,sans]{moderncv}        

\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}

\moderncvstyle{casual}                           
\moderncvcolor{blue}    
\usepackage[scale=0.75]{geometry}

\name{John}{Doe}
\title{Resumé title}                               
\address{street and number}{postcode city}{country}
\phone[mobile]{+1~(234)~567~890}                   
\email{john@doe.org}                               

\begin{document}
\makecvtitle

\section{Education}

\end{document}

still does not compile and produces the error:

!pdfTeX error: pdflatex.EXE (file umvs): Font umvs at 657 not found

==> Fatal error occurred, no output PDF file produced!

texify: pdflatex failed for some reason (see log file).

4
  • Welcome to TeX.SX! Please help us to help you and add a minimal working example (MWE) that illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}.
    – user31729
    Jun 4 '14 at 10:31
  • It looks like you are missing the font files
    – user31729
    Jun 4 '14 at 10:32
  • You need to install MarVoSym, see miktex.org/packages/marvosym
    – egreg
    Jun 4 '14 at 10:48
  • Hi guys, thanks for the responses. Still haven't managed to get anywhere unfortunately. MWE is in answer comment below.
    – LaTexDummy
    Jun 5 '14 at 14:29
47

Your file name database and/or font map is likely broken. This typically happens due to a botched update run. Do

initexmf --mkmaps

initexmf --update-fndb

On MiKTeX, the config tool (now MiKTeX Console, in the "Tasks" menu) has buttons for this, otherwise run the commands on the OS command line.

If you have a multiuser MiKTeX installation (don't, unless you're a university sysadmin or something), you might have to do this in admin mode, which used to be a separate program, and now is another button in the Console program.

10
  • 3
    Thank you for answering. But please give more details or write this as a comment to the question. Your answer is rather short and not very easy to understand for new TeXians. Thank you.
    – LaRiFaRi
    Oct 20 '14 at 11:48
  • 5
    Here's my clarification to Karl Ratzsch's answer which worked for me: run cmd.exe to open the command prompt and give the commands Karl mentioned one after another: initexmf --mkmaps then initexmf --update-fndb keeping tex closed in the meanwhile may be a good idea.
    – user67048
    Nov 28 '14 at 0:35
  • 2
    I had the same problem, this solution works like a charm. Any idea about the cause of the font name database corruption ?
    – Thomas
    Jan 16 '15 at 13:39
  • 1
    Doesn't "fndb" stand for "file name database" instead of "font name database"? This is the explanation for option "--update-fndb" given by "initexmf --help". Sep 24 '16 at 20:01
  • 1
    On my Windows 10 machine, I had this same problem. The buttons found in MikTex settings did not seem to fix the problem, even after clearing the LaTex auxiliary files. However, opening my command prompt, changing to the drive were Miktex is installed and running initexmf --mkmaps and initexmf --update-fndb did fix the issue. Oct 3 '17 at 19:31
7

sorry for bringing up this old question, but I think the answer to your problem is in this thread:

  1. Check C:\Program Files\MiKTeX 2.9\miktex\config\updmap.cfg (if you installed MiKTeX to the regular path) for the entry Map marvosym.map (it shouldn't be there, in your case).
  2. Add the missing entry Map marvosym.map to before mentioned updmap.cfg file and save it (you need Administrator rights to be able to do this).
  3. Run on a cmd.exe from the Start Menu updmap.
  4. Try to compile your document again. It should be working.
3
  • 3
    Thanks a lot for bringing up this old question! :) Running updmap helped! -- While miktex config's "Refresh FNDB" and "Update Formats" didn't.
    – srs
    Jan 25 '17 at 16:48
  • 1
    Thank you really much, that solved my problem. I did, however, already have this entry, so I only executed step 4 and it worked. Absolutely no idea what it does, though :/ tex.stackexchange.com/questions/410506/…
    – Wulfram
    Jan 15 '18 at 16:56
  • 1
    Wulfram, I assume you're talking about step 3 rather than step 4?:) Mar 8 '18 at 5:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.