9

I need to prepare a paper for SIAM. I downloaded the latest template from SIAM website--siamltex1213.zip from http://www.siam.org/journals/auth-info.php. I am using a Basic TexWorks to open the docultex.tex. However, there are two errors like:

! Package hyperref Error: Wrong DVI mode driver option `pdfmark' (hyperref)
because pdfTeX or LuaTeX is running in PDF  mode.

See the hyperref package documentation for explanation. 
Type  H <return>  for immediate help.  ...                                  

l.3925 \ProcessKeyvalOptions{Hyp}

And also:

! Package hyperref Error: Wrong DVI mode driver option `dvips',
(hyperref)                because pdfTeX or LuaTeX is running in PDF mode.

How do I fix this??

  • 1
    Use latex -> dvips -> ps2pdf rather than pdflatex. – Ian Thompson Jun 4 '14 at 15:52
  • 1
    Awesome! I tried dvi2pdf and ps2pdf and they worked! Thank you very much. Could you answer separately so I can pick up your answer? – Appalachian Math Jun 4 '14 at 16:08
7

Use latex -> dvips -> ps2pdf rather than pdflatex.

  • You can also use latex -> dvipdf. – Christian Clason Jun 4 '14 at 16:59
  • How to write your answer in code format , I am beginner – Sudhir Belagali Jun 11 '16 at 8:27
9

This is new in the October 2013 version of the macros, which now include the hyperref package (but with the hard-coded drivers pdfmark and dvips -- which are synonymous, as far as I know). This makes the new version break with pdflatex.

If you would like to continue preparing your paper using pdflatex, you can change your local version of siamltex1213.cls by removing the dvips and pdfmark options from the hyperref call on line 797.


EDIT: This is now fixed in the latest update (January 2016) of SIAM's macros.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.