1

I have a problem using ko.TeX for writing Korean words. I use MikTeX 2.9 with TeXworks as editor and pdfLaTeX as engine. I haven't used ko.TeX package, yet, so when I write Korean words (e.g. 남) as follows:

\documentclass{article}
\usepackage{kotex}
\begin{document}
 남
\end{document}

TeXworks will install missing package (1) kotex-utf and then (2) kotex-plain during compilation but I'm getting this kind of error at the end:

! Missing \endcsname inserted.
<to be read again> 
               \dhucs@serifhangulfont 
1.4 남

Are we able to solve this particular problem?

5
  • Do you really think people will be able to guess what's wrong on the basis of the information you've provided? Please help us to help you and add a minimal (non-)working example (MWE) that illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}.
    – cfr
    Jun 5, 2014 at 1:17
  • Your example is compilable (TL2013, lualatex+xelatex), but I'm missing some fonts. It works for me (TL2013, pdflatex). This is working for me but I'm not using ko.TeX and therefore I'm not solving your question: \documentclass{article} \usepackage{fontspec} \setmainfont{batang.ttc} \begin{document} 남 abc \end{document}
    – Malipivo
    Jun 5, 2014 at 5:53
  • The example compiles on TeX Live 2013; if I try with TeX Live 2012, the error File kotexutf.sty' not found` pops out. I can't test on MiKTeX, but my feeling is that you should do an update of all your packages.
    – egreg
    Jun 5, 2014 at 6:47
  • I have reinstall MikTeX by using the latest version which covers all packages including kotex but the same error happens
    – bnbfreak
    Jun 5, 2014 at 7:52
  • @egreg I also install Tex Live 2013 but I have same errors. Is there any suggestion? maybe I miss something
    – bnbfreak
    Jun 5, 2014 at 10:15

1 Answer 1

1

The kotex-utf package in MiKTeX omits a small file hfontspec.default. You can use cjk-ko instead of kotex-utf with putting [cjk] option to kotex, \usepackage[cjk]{kotex}. Or make a 'hfontspec.default' file by yourself. Visit KTUG (Korean TeX Users Group) wiki site (in Korean).

1
  • I can't for the life of me figure out what the equivalent of \setmainhangulfont is for the cjk package, even after trying to read its manual. How do you keep using the same opentype font as with kotex, instead of whatever cjk wants to use? Jan 7, 2022 at 17:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .