6

Funny, I feel like I had it going before. I can't seem to figure out what's wrong.

MWE:

\documentclass{article}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[danish]{babel}
\usepackage[notes,backend=biber,isbn=false]{biblatex-chicago}
\usepackage{filecontents}
\usepackage{csquotes}
\begin{filecontents}{jobname.bib}
@Book{test1,
  author    = {Bar, Foo},
  title     = {Foo},
  publisher = {Addison-Wesley},
  location  = {Reading, Mass.},
  year      = {1994},
  annote    = {My annotation}
}
\end{filecontents}
\bibliography{jobname.bib}
\begin{document}
Foo\footcite{test1}
\printbibliography 
\nocite{*} 
\end{document}

What I want is the "annote" field at the end of the bibliography entry. No idea why it's not working. You can compile with:

latexmk -pdf mwe

If you want to.

  • 1
    There is the annotation field, it is however not use by the standard biblatex styles ("This field may be useful when implementing a style for annotated bibliographies. It is not used by all standard bibliography styles.", p. 15 §2.2.2 Data Fields). There are addendum ("Miscellaneous bibliographic data to be printed at the end of the entry. This is similar to the note field except that it is printed at the end of the bibliography entry.", p. 15) and note. See the biblatex doicumentation. – moewe Jun 8 '14 at 4:10
  • 1
    OK, since you are using biblatex-chicago, you will need the annotation option: "At the request of Emil Salim, I included in biblatex-chicago the ability to produce annotation annotated bibliographies. If you turn this option on then the contents of your annotation (or annote) field will be printed after the bibliographical reference. This functionality is currently in a beta state [...]." See p. 58, §4.4.3 Style Options – Preamble of the biblatex-chicaho documentation. – moewe Jun 8 '14 at 4:14
  • 1
    The field annote seems to be an alias of annotation, so you can apply my comment on annotation above to annote. – moewe Jun 8 '14 at 4:15
  • Hi @moewe, all that works is addendum, but thanks! I can't figure out if it's a bug in biblatex-chicago or just me doing something wrong, though... – Kristian Nordestgaard Jun 8 '14 at 8:40
  • Did you load biblatex-chicago with the annotation option like so: \usepackage[notes,backend=biber,isbn=false, annotation]{biblatex-chicago}? That worked on my system rather nicely. – moewe Jun 8 '14 at 9:25
7

The annotation field is ignored by the standard biblatex styles

This field may be useful when implementing a style for annotated bibliographies. It is not used by all standard bibliography styles.

biblatex documentation, p. 15, §2.2.2 Data Fields.

You could use the addendum or note field instead

addendum field (literal): Miscellaneous bibliographic data to be printed at the end of the entry. This is similar to the note field except that it is printed at the end of the bibliography entry.

biblatex documentation, p. 15, §2.2.2 Data Fields.

note field (literal) Miscellaneous bibliographic data which does not fit into any other field. The note field may be used to record bibliographic data in a free format. Publication facts such as “Reprint of the edition London 1831” are typical candidates for the note field.

biblatex documentation, p. 15, §2.2.2 Data Fields.


biblatex-chicago has the annotation option

At the request of Emil Salim, biblatex-chicago-notes has, as of version 0.9, added a package option (see annotation below, section 4.4.3) to allow you to produce annotated bibliographies. The formatting of such a bibliography is currently fairly basic, though it conforms with the Manual’s minimal guidelines (14.59). [...] Please consider the annotation option a work in progress, but it is usable now. (N.B.: The BibTeX field annote serves as an alias for this.)

biblatex-chicago documentation, p. 23, §4.2 Entry Fields.

and

At the request of Emil Salim, I included in biblatex-chicago the ability to produce annotated bibliographies. If you turn this option on then the contents of your annotation (or annote) field will be printed after the bibliographical reference. (You can also use external files to store annotations – please see biblatex.pdf §3.11.8 for details on how to do this.) This functionality is currently in a beta state, so before you use it please have a look at the documentation for the annotation field.

biblatex-chicago documentation, p. 58, §4.4.3 Style Options – Preamble.

So in your MWE, all you have to do is to load biblatex-chicago with the annotation option

\usepackage[notes,backend=biber,isbn=false,annotation]{biblatex-chicago}

MWE

\documentclass{article}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[notes,backend=biber,isbn=false,annotation]{biblatex-chicago}
\addbibresource{biblatex-examples.bib}
\begin{document}
  \nocite{wilde}
  \printbibliography
\end{document}

enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.