4

I have been using classicthesis ( http://www.miede.de/index.php?page=classicthesis ) for about a year now with no issues with TeXnicCenter.

I last compiled my document successfully yesterday. Today I updated my MikTex 2.9 packages under Win7 using the Maintenance(Admin) application - I did not pay attention to which packages were updated. I Refreshed FNDB and Updated Formats.

My next compile resulted in 132 errors such as the following:

l.18 \setcounter{paragraph}{0}

The control sequence marked <to be read again> should
not appear between \csname and \endcsname.

! Missing \endcsname inserted.
<to be read again> 
               \endcsname 
l.18 \setcounter{paragraph}{0}

The control sequence marked <to be read again> should
not appear between \csname and \endcsname.

! Missing number, treated as zero.
 <to be read again> 
               \endcsname 
l.18 \setcounter{paragraph}{0}

A number should have been here; I inserted `0'.
(If you can't figure out why I needed to see a number,
look up `weird error' in the index to The TeXbook.)

! Missing \endcsname inserted.
<to be read again> 
               \endcsname 
l.19 \setcounter{subparagraph}{0}

So I re-downloaded classicthesis and compiled it. The result was 101 errors of a similar nature. even with this minimal classicthesis.tex file I get 101 errors. This along with classicthesis-config.tex should hopefully perform the duties of a MWE.

% Copyright (C) 2012 Andr\'e Miede http://www.miede.de

\documentclass[ twoside,openright,titlepage,numbers=noenddot,headinclude,%1headlines,%     letterpaper a4paper
            footinclude=true,cleardoublepage=empty,abstractoff, % <--- obsolete, remove (todo)
            BCOR=5mm,paper=a4,fontsize=11pt,%11pt,a4paper,%
            ngerman,american,%
            ]{scrreprt}

\input{classicthesis-config}

\begin{document}
\end{document}

I have used the classicthesis-config.tex example file and my modified file with the same result. Relevent files are available at: http://www.ctan.org/tex-archive/macros/latex/contrib/classicthesis/

%http://mirrors.ctan.org/macros/latex/contrib/classicthesis/classicthesis-config.tex
%http://mirrors.ctan.org/macros/latex/contrib/classicthesis/classicthesis.sty

I have tried deleting all the .aux files. In my dissertation, removing \usepackage[polutonikogreek,english]{babel} results in some 50 errors fewer, but this does not occur in the attached example.

Given that I have relied on \usepackage[polutonikogreek,english]{babel} for extensive ancient Greek text, I really need to use this.

Any ideas as to the cause and/or the remedy for my woes? Thank you for your time thus far.

closed as off-topic by Johannes_B, Svend Tveskæg, moewe, user31729, barbara beeton Feb 17 '15 at 16:39

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • At first, I thought, the - character in \input{classicthesis-config} could be the source of the problem, but after tests, your example runs without errors, if I use the latest version of TeXLive and also of classigthesis-config. I can however say nothing about the changes you made. Please provide your version of that file also. – user31729 Jun 8 '14 at 20:57
  • Why don't you use \usepackage{classicthesis}? – user2478 Jun 8 '14 at 21:07
  • Thank you Christian. The examples I provided are the example files created by the author of the classicthesis package. Compiling his example files resulted in the same errors as compiling my files, thus I thought supplying his files would ease this process. Solving the problem of compiling the examples should solve the problem of compiling my files. However, as they compile without error for you, I suspect there is now some issue on my installation of MikTex. – Evyn Jun 8 '14 at 23:38
  • Herbert, the example I supplied is the example provided by the classicthesis author. Up until today, the example he provided worked perfectly for me, so I didn't change it. – Evyn Jun 9 '14 at 0:11
  • 4
    I'm voting to close this question as off-topic because see comment above – Johannes_B Feb 17 '15 at 16:14

Browse other questions tagged or ask your own question.