Very simple really. I installed TeXnicCenter, Adobe Reader X and MiKTeX 2.9.

Tried to build a code in the PDF format. I get 4 new files but no .pdf file. Yet another option listed as LaTeX => PS => PDF does produce the required result?

What is going on?

  • 4
    Hard to tell without some more information. If I understood your question correctly, the profile LaTeX=>PS=>PDF gives you a final PDF document, while the compilation through LaTeX=>PDF fails? If that is so, then perhaps your document contains Postscript material (for example, code from PS-Tricks or images in EPS format) which requires the first compilation profile. – Gonzalo Medina May 16 '11 at 21:31
  • That is correct but it doesn't appear to be a problem with the latex code as it is very simple. The error message Texniccenter produces is: [DocOpen("%bm.pdf")][FileOpen("%bm.pdf")] Cannot execute the command. – Steve Rogers May 16 '11 at 21:56
  • I've just attempted to build another code and now only .log file is being produced and no build profile is working... – Steve Rogers May 16 '11 at 22:01
  • It seems that the PDF file is in fact produced but TeXnicCenter cannot open it with your viewer. Compile with the problematic profile and then go to the folder containing the .tex file and see if the PDF file was produced (you can open it manually); that would mean that the problem comes from the TeXnicCenter settings for the PDF viewer. – Gonzalo Medina May 16 '11 at 22:04
  • 1
    Yes; sorry. I was writing my comment and didn't see your new answer. Have you tried compiling from the command line to rule out a problem with your LaTeX installation? – Gonzalo Medina May 16 '11 at 22:08

If a pdf is produced (apart from looking in the output folder, TexnicCenter will tell you the number of pages in the pdf file: if that's greater than 0 then the pdf file has been produced) then you may need to adjust the TexnicCenter settings to cope with Adobe Reader X. Full details of how to do this are at TexnicCenter and Adobe Reader 10 / X. Please also read the comments for extra information.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.