3

I am currently using the thesis class as in

\documentclass[11pt, a4paper, oneside]{Thesis}

when I put the tableofcontents it creates a selfreference to it that I don't want.

I have tried using \tableofcontents* with no success. Any other ideas?

I've gotten the template from http://www.latextemplates.com/template/masters-doctoral-thesis

  • 1
    Welcome to TeX.SX! Which class exactly is this, can you add a link? – Torbjørn T. Jun 9 '14 at 8:03
  • I would assume, that either \let\addtocontents\relax or \let\addcontentsline\relax just before \tableofcontents could be helpful – user31729 Jun 9 '14 at 8:06
  • Any of those work. The first one prompts a lot of errors while the second one breaks the class style everywhere. – Jesús Ros Jun 9 '14 at 8:08
  • @gunbl4d3: I will look into it – user31729 Jun 9 '14 at 8:09
  • Ok. it was an option buried inside the Thesis.cls. It had an entry stating \addtotoc{Contents}. Commenting it solves the problem. – Jesús Ros Jun 9 '14 at 8:13
3

Open up Thesis.cls, find line 326 which reads

\addtotoc{Contents}

Either remove this, or add a % at the beginning, i.e. %\addtotoc{Contents}.

  • Just found the same. TY. – Jesús Ros Jun 9 '14 at 8:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.