0

When I use

\documentclass{beamer}

\setbeamertemplate{caption}[numbered]
\usepackage{subfigure}

\begin{document}
\begin{frame}

\begin{figure}
\subfigure[Subfig 1]{
}
\hfil
\subfigure[Subfig 2]{
}
\caption{Figure}
\end{figure}

\end{frame}

\end{document}

, it gives

. Note that the font color of the figure caption and sub-figure captions are differnt. Now, how can I stylize (i.e., change color, change size, make bold, use roman numerals etc.) the sub-figure captions? I noticed that something like \usepackage[font=normalfont, labelfont={red,bf}]{caption} does not work with beamer.

  • tex.stackexchange.com/questions/127354/… -Helped me with the color. – Kidja Feb 8 '15 at 1:32
  • possible duplicate of Subcaption with Beamer – Amar May 31 '15 at 16:20
  • \usepackage[...]{caption} should work with beamer. If not, please fill out a ticket: sourceforge.net/p/latex-caption/tickets – Axel Sommerfeldt Aug 12 '16 at 8:18
  • @AxelSommerfeldt I think \usepackage[...]{ca‌​ption} has no effect whatsoever. I'll report it. Thanks... – xxx--- Aug 15 '16 at 14:52
  • @pushpen.paul I just inserted \usepackage[font=normalfont, labelfont={color=red,bf}]{caption} in your example document and it has an effect here., at least on the main figure caption. However, of course this does not have any effect on the sub-captions since the (ancient) subfigure package is not using these options. Only subfig and subcaption uses them. – Axel Sommerfeldt Aug 16 '16 at 7:49
1

Brute force solution: redefine \thesubfigure to use the colour you want:

\documentclass{beamer}

\setbeamertemplate{caption}[numbered]
\usepackage{subfigure}

\renewcommand{\thesubfigure}{\protect\usebeamercolor[fg]{caption name}\relax(\arabic{subfigure})}


\begin{document}
    \begin{frame}

        \begin{figure}
            \subfigure[Subfig 1]{
            }
            \hfil
            \subfigure[Subfig 2]{
            }
            \caption{Figure}
        \end{figure}

    \end{frame}

\end{document}

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.