6

I'm creating a draft document template (article). I need the draft watermark on every page except the titlepage, but it's skipping the List of Figures. The problem seems to be coming from the second setcounter, where the number restart in Arabic, because removing that makes the draft show up on the List of Figures. How do I fix it?

\documentclass[printwatermark]{article}
\usepackage{xwatermark}
\usepackage{xcolor}
\usepackage{lipsum}%used to generate false content

\newwatermark[allpages,color=gray!25,angle=45,scale=5,xpos=0,ypos=0]{DRAFT}%determines watermark characteristics

\begin{document}

%starts page numbers at i
\setcounter{page}{1}
\renewcommand{\thepage}{\roman{page}}

NOTICES:\linebreak
\lipsum[1-2]
\newpage

\tableofcontents
\newpage

\listoffigures
\newpage

%starts page numbers at 1
\setcounter{page}{1}
\renewcommand{\thepage}{\arabic{page}}

\section{Demo Section}
\lipsum[1-2]
\subsection{Demo Subsection}
\lipsum[1-2]
\subsubsection{Demo Subsubsection}
\lipsum[1-2]
%includes figure in list of figures
\begin{figure}[h]
\includegraphics[width=.5\linewidth]{PlaceHolder}
\centering
\caption{Demo Graphic}
\label{fig:figure1}
\end{figure}

\end{document}

I've searched through the xwatermark guide, stackexchange, etc, but I can't find anything about the two conflicting.

4

This is to show you another option with powerful background package. Just adding \usepackage{background} will add the the Draft text.

\documentclass{article}
\usepackage{background}
\usepackage{lipsum}%used to generate false content


\begin{document}

%starts page numbers at i
\pagenumbering{roman}

NOTICES:\par
\lipsum[1-2]
\clearpage

\tableofcontents
\clearpage

\listoffigures
\clearpage

%starts page numbers at 1
\pagenumbering{arabic}

\section{Demo Section}
\lipsum[1-2]
\subsection{Demo Subsection}
\lipsum[1-2]
\subsubsection{Demo Subsubsection}
\lipsum[1-2]
%includes figure in list of figures
\begin{figure}[h]
\includegraphics[width=.5\linewidth]{PlaceHolder}
\centering
\caption{Demo Graphic}
\label{fig:figure1}
\end{figure}

\end{document}

enter image description here

You can customize the background contents with \backgroundsetup

\backgroundsetup{
scale=15,
color=gray!40,
angle=45,
opacity=1,
contents= {Draft}
}

enter image description here

contents= can be anything like a tikzpicture or any picture/text.

If you don't want the background for just one page like title page, use \NoBgThispage in that page.

%\thispagestyle{empty}
\NoBgThispage
This is the title page
\clearpage
  • That was incredibly helpful for working around my issue quickly, but I'm going to leave this question open for a bit, just to see if anyone knows why it was conflicting. – PixPrefect Jun 10 '14 at 23:07
  • @PixPrefect: To leave title page without background, use \NoBgThispage inside title page. I have updated the answer. – user11232 Jun 10 '14 at 23:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.